Problem installing SLK

Topics: Developer Forum, Project Management Forum, User Forum
Oct 20, 2007 at 10:59 AM
At last I managed to install SLK.
But I got very strange error assigning this kit...

Failed to instantiate provisioning provider 'Microsoft.SharePoint.Publishing.PortalProvisioningProvider'
from assembly 'Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral,
PublicKeyToken=71e9bce111e9429c' during provisioning: Could not load file or assembly
'Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'
or one of its dependencies. The system cannot find the file specified.

Can anybody help me please?
Nov 3, 2007 at 6:17 PM
I have exactly the same problem. I am using W2K3 R2 servers, SQL2005SP1 and MOSS.
I followed the Learning Gateway Installation and Configuration document and got the error
while trying to create a sub-site using the eLearning -> School Portal Site template.

I see in the documentation that the site being used had Publ;ishing as a template heading,
my installation doesn't.

My suspiscion is that the Portal Server is required and MOSS just isn't going to do it.
I am going to install Portal Server and try the installation again.

I will let you know what happens.
Nov 4, 2007 at 3:09 PM
Ooops, A correction to my last post. This speaks to my inability to dechipher the names of the various MS SharePoint incarnations...

I encountered the above problem whaen using SharePoint 3.0, I moved to MOSS 2007 Enterprise, and got past this issue. I have encountered another problem, but that will be another post :-)

So MOSS 2007 is REQUIRED not optional.
Nov 6, 2007 at 7:59 AM
Hi!

Thanks for your answer. But how can I resolve it without installing of MOSS 2007?
Can you please help me?

Thanks again. Alex.
Nov 6, 2007 at 12:46 PM
You cannot. There are componnets of MOS 2007 that are required for the MLG & SLK. If you don't have MOSS 2007 it will not work!

Dave
Coordinator
Nov 6, 2007 at 3:23 PM
Edited Nov 6, 2007 at 3:25 PM
FYI, I installed SLK 1.2.002 onto Sharepoint 3.0 (the non-MOSS version) just yesterday. There are no MOSS dependencies in the SLK release you can install from this project site. I followed the "Getting Started" Guide included in the release download.

I'm not familiar with the LG extensions to SLK, there may be MOSS dependencies there.

- jcb


w0001135 wrote:
You cannot. There are componnets of MOS 2007 that are required for the MLG & SLK. If you don't have MOSS 2007 it will not work!

Dave

Nov 7, 2007 at 6:26 AM
Thanks.

I also installed SLK following the "Getting Started" Guide. And it works!
But if you create new site choosing not Team for example but School portal site or another (cannot recall) this error appears...
Nov 7, 2007 at 12:29 PM
All,

Publishing Features of MOSS 2007 are required for MLG site templates (School Portal Template) and that's clarify why the MOSS is added in the
MLG Installation Prerequisites in the MLG Deployment Guide.

This is totally MLG behavior that doesn't affect SLK which can work with WSS 3.0 without having MOSS installed

Regards,
kelhossainy