Connecting AssignmentList wp

Topics: Developer Forum
Jan 30, 2008 at 8:17 AM
we have installed 1.3.1 alpha, and have it working OK. However we need to use it in conjunction with the Learning Gateway 'My Children' webpart, by connecting the two (as in the original LG installation - LG Refresh published June 25th 2007 http://www.codeplex.com/LG/Release/ProjectReleases.aspx?ReleaseId=4397).
In this way the studentname is passed to the ALWP rather than the logged in parent. Unfortunately the ALWP in 1.3.1 gives the message that it does not support connections - is this correct?
Feb 1, 2008 at 10:49 AM
Hi mkl, if you are using this release https://www.codeplex.com/Release/ProjectReleases.aspx?ProjectName=SLK&ReleaseId=9206, then this should work. Can you give the exact steps that you have followed to connect the two webparts, the exact point of the error and the entire error message?
Feb 1, 2008 at 4:00 PM
We have now moved past this error having reinstalled v1.3.1 alpha. The web part version in the GAC is 1.3.0.2 - is this the correct version? Have followed through the install instructions and finally added the web part to the gallery on a test site. However when we preview the web part the following error occurs:

This site is not configured to use SharePoint Learning Kit. Administrators can use SharePoint Central Administration to configure SharePoint Learning Kit.

We have previously deactivated and reactivated SLK on this website via Site Features as per the install instructions. We are upgrading from v1.2 and have configured SLK with a new database, set up the observor role permissions and used the new slk settings file. We are on a 64 bit OS.

Any suggestions on how we can resolve this error? Thanks