Making Assignments for non-eLearning content is slow

Topics: Developer Forum, User Forum
Jul 22, 2010 at 6:35 PM

When I make an assignment for non-eLearning content, the assignment creation will take 3+ minutes to complete.  If I make an assignment for an eLearning content, then the assignment is made immediately.  I have checked the database (SQL Server 2008 cluster) and SharePoint for performance problems, but have not found any.  that leads me to believe that the SLK is the problem.

Does anyone have any ideas?

 

thanks,

Keivn

Coordinator
Jul 30, 2010 at 6:29 PM

With non e-learning content, SLK has to do some back end work in the drop box. How many users do you have on the site you are assigning to? I've done some performance improvements for version 1.5.

Richard

Project Coordinator

http://blog.salamandersoft.co.uk

Jul 30, 2010 at 6:37 PM
Edited Jul 30, 2010 at 7:23 PM

Hi Richard,

 

Currently we have around 230 users, but ultimately we will have around 1000.

 

I finally managed to get the latest source code to build. Turned out there was two missing .bat files and the cab.ddf was messed up. With the latest version it still is slow. However, I did not do an iisreset. I will try that and test again.

 

Thanks,

Kevin

 

Jul 30, 2010 at 7:23 PM

After doing an iisrest, the problem still exists.

Kevin

Coordinator
Jul 30, 2010 at 10:16 PM

The latest checked in version doesn't have the performance improvements in. They are still in my working copy.

Jul 30, 2010 at 10:29 PM

ok.  When did you expect the next version to be ready?