SLK 1.5 SP2007 install issue

Topics: Developer Forum, User Forum
Aug 13, 2010 at 11:33 AM
Hi, Im trying to install 1.5 to a SharePoint 2007 installation and it adds the solution fine but when I try to deploy I get the following error: Error: Cannot add the specified assembly to the global assembly cache: Microsoft.LearningComponents.MRCI.dll. Has anyone else had this problem or shed some light on it. Any help would be greatly appreciated.
Aug 19, 2010 at 1:49 PM

Hi,

had same issue.

after hours i found the problem:

your "Src\Compression\Compression.sln" has Release or Debug Setting "Mixed Platforms" change it to "Win32". Our Compilier tries to use x64 on building our dll, but the dll will become broken!

Greetings

Coordinator
Oct 20, 2010 at 10:00 AM

I've just rewritten MRCI in managed code and merged into Compression so that shouldn't be a problem from the next release.

Richard

SLK Coordinator

http://blog.salamandersoft.co.uk