SLK Permission Levels not created

Feb 9, 2011 at 2:33 PM

After having problem using 1.5RC I have now switched to back to 1.4 and all was looking well, on my main site the custom SLK permission levels have been created and I can assign them to users or groups. However on 2 sub sites these permission levels are not visible, I have tried disabling and re-enabling the feature to no avail. I have assigned e-learning actions to myself which works fine but I can’t assign to the site because I’m not a member of the SLK Instructor's group.

I tried just recreating the group name myself but that didn’t help either, does anyone have an idea what else I could try.

Many thanks
Rob

Coordinator
Feb 10, 2011 at 9:49 AM

Hi Rob,


Are the sub-sites in separate site collections? You need to configure SLK on a per site-collection basis.

Richard

SLK Coordinator

http://blog.salamandersoft.co.uk

Feb 10, 2011 at 7:38 PM

They are all sub sites in the same site collection.

Coordinator
Feb 11, 2011 at 4:01 PM

I can only think that those sites do not inherit permission levels from their parents. Have a look at

http://siteurl/_layouts/role.aspx

Feb 12, 2011 at 3:03 PM

That right, the 3 sub sites all have there own permission levels not inherited. However one of the three does have the SLK permission sets.
Is there anything I can do to invoke those permissions levels to be created on the other two sites?

Thanks for your help,
Rob

Coordinator
Feb 12, 2011 at 6:24 PM

No. You'll have to create them manually .

Feb 14, 2011 at 10:25 AM

I tried creating a blank group with exactly the same name and description but that didn’t work. Is there another way?

Coordinator
Feb 14, 2011 at 11:43 AM

That's strange as I did that and it worked perfectly. I couldn't create a blank group though, I had to put some permissions in so I just gave it read.

Feb 14, 2011 at 1:53 PM

Right I tried it again and it has worked, perhaps I had a space in the name or something simple like that.

Thanks Richard.