MOSS 2007 final Deployment issue

Topics: User Forum
Dec 5, 2006 at 5:02 AM
Once the deploysolution command is executed it all goes through fine. This is the result of the deployment


<Solutions Count="1">
<Solution Name="sharepointlearningkit.wsp">
<Id>00057001-c978-11da-ba52-00042350e42e</Id>
<File>sharepointlearningkit.wsp</File>
<Deployed>FALSE</Deployed>
<WebApplicationSpecific>TRUE</WebApplicationSpecific>
<ContainsGlobalAssembly>TRUE</ContainsGlobalAssembly>
<ContainsCodeAccessSecurityPolicy>FALSE</ContainsCodeAccessSecurityPolicy>

<SolutionDeploymentJob id="cf5beead-a90a-4be7-825f-6d07ecb1103c">
<Title>Windows SharePoint Services Solution Deployment for "sharepointl
earningkit.wsp"</Title>
<Type>Deployment</Type>
<State>Pending</State>
</SolutionDeploymentJob>
</Solution>
</Solutions>

I have removed the job from timer job definitions and rerun it and deployed it with the -force command. Still no luck. Any suggestions out there. I am running 2003 R2 server and its not a DC. Its failing on
ContainsCodeAccessSecurityPolicy but unsure on how to resolve.
Dec 5, 2006 at 7:13 PM
I notice in your output that the job is still "pending". Have you waited until EnumSolutions has a state of DeploymentSucceeded or failed?

Assuming you deploy using the DeploySolution script, it deploys "immediately", but it may actually take a minute or so before the server runs the deployment. It is in the "pending" state while it is waiting.
May 3, 2007 at 1:41 PM
I have a similar problem. My deployment is in a 'pending' state. Its been there for while - a clues as to where I can troubleshoot it. I have checked the logged files. Interestingly enough there is no entry for it in the site administration > operations > timer job definitions

May 3, 2007 at 3:13 PM
I've experienced the same thing sometimes. Tried to deploy through the cmd files but sometimes it hangs showing pending. What I do is to go to the Solution Management on Central Admin and cancel the deployment. Then it will show the solution as not deployed. Then I use the Deploy Solution option from Central Admin which deploys it right away. I'm not sure if it's a problem with the SharePoint timer service, but this has worked for me...