AssignmentList NullReference exception

Topics: Developer Forum, User Forum
Nov 15, 2011 at 1:07 PM

Hi Everyone,

Our installation : slk 1.4 (release SLK_203bdbbcb32c) on Moss 2007 , Windows server 2008 r2.

We used to have slk 1.3 everything worked ok .

We created a new environment and installed 1.4 and copied the databases from the old  to the new databases .

Applied the patch of Upgrade131To14.sql from http://slk.codeplex.com/releases/view/38555#DownloadId=194578 .

For some reason the assignmentlist is not showing any results to the learners ( for teachers it works ok ).

In the toolbar on the left side the learner sees all the categories (for example 'To Do', 'Overdue',..) with the correct number of assignments ,

but when clicking on one of them instead of showing the learner all his assignments the user gets the following error :

An error occurred. More information may be available in the server event log.

In the eventviewer we get the following error :

SharePoint Learning Kit Error

System.NullReferenceException: Object reference not set to an instance of an object.

at Microsoft.SharePointLearningKit.ApplicationPages.AlwpQueryResults.RenderQueryResults

(QueryDefintion querydef, List1 renderedRows, HtmltextWriter hw)

at Microsoft.SharePointLearningKit.ApplicationPages.AlwpQueryResults.Page_Load(Object sender, EventArgs e) .

We forgot to mention but the assignmentlist is only showing 2 columns in the header ( 'assignment' and 'status').

Any help would be appreciated !

Thx Michael

 

 

 

Nov 16, 2011 at 11:32 AM
Edited Nov 16, 2011 at 11:32 AM

Hey everyone ,

We found the problem !

We created some slk queries in slksettings.xml file (those worked fine in 1.3 ).

But for some reason in slk 1.4 they demands you to use the column-name 'assignmentSpWebGuid' in the query .

That is a bit strange , no ?