karthikeyan.R

Topics: Developer Forum, Project Management Forum, User Forum
Dec 22, 2011 at 5:47 AM

I have installed slk1.5 and deployed solution in my share point 2010 server. i have done Activate the feature.

 Site Actions | Site Settings | Mange Site Features. Activate the appropriate features chosen from:

i. SharePoint Learning Kit. Allowing assigning of resources to any site in the site collection.

ii. SharePoint Learning Kit - Assign Self. Allowing quick assigning to the logged in user.

iii. SharePoint Learning Kit - Assign To Site. Allowing quick assigning to learners in the current site.

 

even though i am unable to enable

Assignment List Web Part under the Galleries> webparts

 

error is

This site is not configured to use SharePoint Learning Kit. Administrators can use SharePoint Central Administration to configure SharePoint Learning Kit.

Coordinator
Dec 22, 2011 at 7:40 AM

You need to configure the site collection to support SLK. It uses it's own database so this either needs to be created or pointed to an already existing one.

To do this you need to go into Central Administation and there's a link to configure SLK under Applications.

Richard

SLK Coordinator

http://blog.salamandersoft.co.uk

Dec 23, 2011 at 6:08 AM
Edited Dec 23, 2011 at 12:50 PM

i have already done that same....

after that also i am getting error on my site...


A Web Part or Web Form Control on this Page cannot be displayed or imported. The type is not registered as safe.

 

Troubleshoot issues with Microsoft SharePoint Foundation.

Correlation ID: 95d25e46-4e87-4baf-856e-4d83a171701d

Date and Time: 12/23/2011 11:40:17 AM

 could you tell me the possible time, when i could chat with you regarding  issue...?

Jan 10, 2012 at 3:53 PM

Hi, I have the same issue, when i try to create a new site with Learning Template it tells me that it needs to be configured on Central Admin or Site Collection which I already did. What am I missing? Does the database needs to be configured differently, any specific permission? I have installed it on SharePoint 2010 by the way.

Any help will be greatly appreciated.

Thanks,

Coordinator
Jan 23, 2012 at 9:16 AM
karthirk2k7 wrote:


A Web Part or Web Form Control on this Page cannot be displayed or imported. The type is not registered as safe.


Have you deployed the solution to the web application?

Coordinator
Jan 23, 2012 at 9:17 AM
jessemeister wrote:

Hi, I have the same issue, when i try to create a new site with Learning Template it tells me that it needs to be configured on Central Admin or Site Collection which I already did. What am I missing? Does the database needs to be configured differently, any specific permission? I have installed it on SharePoint 2010 by the way.

Any help will be greatly appreciated.

Thanks,

Make sure that you have configured the correct site collection. It's very easy to configure the wrong site collection as the one defaulted to in the admin page is never the right one.

Jan 23, 2012 at 2:14 PM
Good Morning Richard,

Actually, we put this task on hold as the this requires a second tool in order to get the training to work properly, but it only supports SharePoint 2007. As my understanding this tool will allow me to create trainings but if I install it by it self it tells me it needs to be installed on the Site Collection which it has and verified it several times. One of our Supervisors said that he has done this before but in SharePoint 2007. This does not help us in SharePoint 2010.

However, I'm still upset why this tool would not work by itself and keep saying that it needs to be installed properly on the Web Application or Site Collection.

Thanks,

On Mon, Jan 23, 2012 at 3:16 AM, RichardWillis <notifications@codeplex.com> wrote:

From: RichardWillis

karthirk2k7 wrote:


A Web Part or Web Form Control on this Page cannot be displayed or imported. The type is not registered as safe.


Have you deployed the solution to the web application?

Read the full discussion online.

To add a post to this discussion, reply to this email (SLK@discussions.codeplex.com)

To start a new discussion for this project, email SLK@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com