Configuration error - Named Pipes Provider, error: 40 - Could not open a connection to SQL Server

Topics: User Forum
Jul 24, 2008 at 10:05 PM
 

Hi,

I've keep getting this error when I try to configure SLK in CA > App Mgmt. I have installed MS SQL Server 2005 on Windows Server 2003. I am running a stand-alone version of MOSS 2007 Enterprise Edition.

Error message: "An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

More information has been written to the server event log."

 

Below are the other services that are running/enabled. I'm not a guru when it comes to software install/configuration. Any suggestions on what I should do to fix this?

 

SQL Server (OFFICESERVERS) running

SQL Server Browser running

Protocols for OFFICESERVERS enabled: Shared memory, Named Pipes, TCP/IP

SQL Native Client configuration enabled: Shared memory, Named Pipes, TCP/IP

I have verified that under SQL Server 2005 Surface Area Configuration that Local and remote connections has Both TCP/IP and Named Pipes enabled

 

Server Event Log description: Login failed for user 'NT AUTHORITY\LOCAL SERVICE'. [CLIENT: 192.168.100.101]

Event ID: 18456

 

Prior to enabling some of the protocol settings, I was getting this same error as above, but with a different Event ID: 6102. I followed these instructions - "Changing the service account of the Document Conversions Load Balancer Service in "Central Administration/Operations/Service Accounts" window to "Network Service".  but that did not resolve my issue.

 

I have stopped/started the SQL service, restarted the DC and MOSS server, and searched many different articles, but I still cannot find a resolution. Help?!?