Can Report1.aspx from SLK-33333 be used with SLK 1.3.0.2 release version?

Topics: Developer Forum
Aug 20, 2008 at 8:15 AM

I have the release version of SLK (1.3.0.2) installed on our server, and I tried out the report pages that come in the Slk\Samples\ReportPages folder of the latest build (SLK-33333). The SiteCollectionInfo.aspx page works fine, but both of the Report[12].aspx pages throw an error (below). Anyone know whether there is something in the latest build that wasn't included in the 1.3.0.2 release that is needed? The error I get is:-

The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)   at System.Reflection.AssemblyName.nInit(Assembly& assembly, Boolean forIntrospection, Boolean raiseResolveEvent)
   at System.Reflection.AssemblyName.nInit()
   at System.Reflection.AssemblyName..ctor(String assemblyName)
   at System.Web.Configuration.CompilationSection.LoadAssembly(String assemblyName, Boolean throwOnFail)
   at System.Web.UI.TemplateParser.LoadAssembly(String assemblyName, Boolean throwOnFail)
   at System.Web.UI.TemplateParser.AddAssemblyDependency(String assemblyName, Boolean addDependentAssemblies)
   at System.Web.UI.TemplateParser.ProcessDirective(String directiveName, IDictionary directive)
   at System.Web.UI.BaseTemplateParser.ProcessDirective(String directiveName, IDictionary directive)
   at System.Web.UI.TemplateControlParser.ProcessDirective(String directiveName, IDictionary directive)
   at System.Web.UI.PageParser.ProcessDirective(String directiveName, IDictionary directive)
   at System.Web.UI.TemplateParser.ParseStringInternal(String text, Encoding fileEncoding)


Thanks in advance,

Ron
Coordinator
Aug 20, 2008 at 3:11 PM
Edited Aug 20, 2008 at 3:12 PM
Hi Ron,

Try changing the line
<%@ Assembly Name="Microsoft.LearningComponents.Storage, Version=%VERSION4%, Culture=neutral, PublicKeyToken=24e5ae139825747e" %>
in each file to
<%@ Assembly Name="Microsoft.LearningComponents.Storage, Version=1.3.0.2, Culture=neutral, PublicKeyToken=24e5ae139825747e" %>

Regards,
Richard

SalamanderSoft Limited
http://www.salamandersoft.co.uk
Active Directory & SharePoint provisioning


Coordinator
Aug 25, 2008 at 6:52 PM
I've created bug http://www.codeplex.com/SLK/WorkItem/View.aspx?WorkItemId=18091 for this issue.
Coordinator
Aug 25, 2008 at 7:32 PM
Hi Jay,

I'd already created one here
http://www.codeplex.com/SLK/WorkItem/View.aspx?WorkItemId=17974

Probably should have posted about it. You'll need to merge them or delete one.

Regards,
Richard
Coordinator
Aug 25, 2008 at 11:16 PM

Beautiful, thank you very much.

FYI, a fix has been checked in for this issue in the Reports and two other locations I found the same bug in the code.