Sharepoint learning kit:Facing error when assigning a document using Elearning actions

Topics: Developer Forum, Project Management Forum, User Forum
Mar 30, 2012 at 1:52 PM

Hi,
I have installed and configured sharepoint learning kit to my project.After configuring i added a document to document library to sharepoint site.right click on the document and click on E-learning actions.I want to assign the people which is present in my sharepoint site.when i click on the site to assign it displays an error please check the event log to see the error.
The error is 
SharePoint Learning Kit ErrorSystem.InvalidOperationException: More than one item matches the properties in the AddOrUpdateItem command.   at Microsoft.LearningComponents.Storage.LearningStoreJob.Execute()   at Microsoft.SharePointLearningKit.SlkStore.GetCurrentUserId()   at Microsoft.SharePointLearningKit.SlkStore.GetNewAssignmentDefaultProperties(SPWeb destinationSPWeb, String location, Nullable`1 organizationIndex, SlkRole slkRole, LearningStoreXml& packageWarnings)   at Microsoft.SharePointLearningKit.ApplicationPages.AssignmentPropertiesPage.OnPreRender(EventArgs e)
Please help me to resolve the error

Coordinator
Apr 4, 2012 at 7:40 PM

Check in the useritem table to see if there's any rows with duplicate keys.

Richard

SLK Coordinator

http://blog.salamandersoft.co.uk

Apr 6, 2012 at 8:28 AM

Hi ,

There is no duplicate keys present in useritem table and one thing 

If I login as site collection administrator Assigntoself is working but assign to site is not working other than site collection administrator both are not working.

 

please help me asap.