Problem installing Course Manager on 1.3.1 RC1

Sep 17, 2008 at 11:11 PM
Edited Sep 18, 2008 at 6:56 PM
I'm attempting to install the Course Manager downloaded from the 1.3.1 RC1 release page. I had previously successfully installed SLK 1.3.1 RC1. When I run the installer.bat e.g.:
installer https://server.company.com:443

I get the following error message:

Checking SharePoint Learning Kit (SLk) Version 1.3.1...

ERROR: SLK Version 1.3.1 is not installed

ERROR: Course Manager could not be installed correctly

Has anyone else run into this problem, or been able to get this to install? Could I simply comment out this check in the installer.bat file?

Sep 18, 2008 at 11:12 PM
Yes, you can just comment out the check.
Sep 26, 2008 at 4:25 PM
The reason for the error is the version 1.3.0.2  (which was the version of the Alpha release) is hard coded into the check application that is run.

You will also find that even if you skip this step the code that is deployed still references 1.3.0.2 in various places,   see post http://www.codeplex.com/SLK/Thread/View.aspx?ThreadId=34659

As you will see from this post the code is available but we have had no updates to the package since 27th August.

Andrew