Course Manager error - Unknown server tag 'asp:ScriptManager'

Topics: Developer Forum, Project Management Forum
Nov 18, 2008 at 11:54 AM

I've faced the next problem with Course Manager:
In Course Manger pages webpart when cllicking at Plan and Assign link i'm getting the error message - "An error occurred during the processing of . Unknown server tag 'asp:ScriptManager'."
It seems like problem is with AJAX clases recognision. I've tried to change web.config (adding 
<pages>

      <controls>

               <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

      </controls>

  </pages>

 ) - but no success.

Do someone have any ideas?
Please help..
Thanks.

Nov 19, 2008 at 7:15 PM
Interesting, I have not seen this issue yet. A couple of questions:

 

  • Are you installing on a farm or single server?
  • Have you been able to access that page before? Is the Plan & Assign web part on that page?
  • Did you use the Configuration form to setup the Course Manager?
  • Do you have .NET 3.5 installed on the server?
  • Does Monitor & Assess work, or does that have problems too?
Nov 19, 2008 at 9:01 PM
I'm getting the same thing on a fresh installed MOSS 2007, single server. I was never able to access these pages.
I configured the course manager in central admin, but all I had to specify was the db server name and the db name, is that all?
I have .Net 3.5 installed, and have the same problem in Monitor & access.

I'm getting dcom errors in the event log every time I try to access the pages: 

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{3D42CCB1-4665-4620-92A3-478F47389230}
 to the user COMPANY\moss_db SID (S-1-5-21-4038079582-2954899176-3431056408-1112).  This security permission can be modified using the Component Services administrative tool.

Nov 19, 2008 at 9:22 PM

All you need to do is fill out the form in Central Administration. It does look like something went wrong though. After the form completed, did you see a success message, or just the form again? Did you make sure to configure it for the right site collection? There is a drop down box above the DB Name field. Also, what is the Application Pool Identity for the Web Application. It uses this account to try and configure the CM.

To verify the Configuration:

  • Verify the DB has been created and it has about 10 tables
  • Check the registry (for exactly key, see documentation)
  • Verify the proper web.config edits were done on the proper web application (See documentation)

As for the second error you are seeing in the Event Log, this is a common MOSS problem. See the following link: http://www.sharepointblogs.com/jasonmedero/archive/2008/02/08/after-applying-moss-2007-sp1-event-log-error-retrieving-the-com-class-factory-for-component-with-clsid-3d42ccb1-4665-4620-92a3-478f47389230-failed-due-to-the-following-error-80070005.aspx

Nov 21, 2008 at 10:35 AM
Hi Skifaster,
Answering your questions :
- I have small farm but it is installed on the single BOX , SQL Server instance is separated but it is located at the same box
- Yes - there is plan and assign webpart on the page - but when I'm clicking links, plan and assign and the second one (do not remeber the name) i'm getting mentioned error
- Yes I did
- Yes I have it installed and up to date
- No - Monitor&Access link does not work - the same error 

Do you have any ideas how to solve this? And by the way - the installation guide appendix saying that after installation my web.config will be changed (updated), but I don't see any changes in my web.config.
I've tried to reinstall CourseManager and even to add that changes to my web.config manually - but no luck..
Nov 29, 2008 at 3:50 AM
Hi, I have also the same problem....after filling out the form in Central Administration,
It appears the form again without any succes message
and the Folder SLKCOURSEMANAGER in the registry-folder dont exist : (
do u have any proposal to solve this???
thank u

 

Jan 30, 2009 at 9:27 AM
If someone is still trying to figure it out. If you add all the entries in the webconfig mentioned in the installation guide Appendix B then it should resolve the issues.It resolved for me atleast!
Jan 30, 2009 at 4:53 PM
AdApa,

If you are trying to install CM on a SharePoint Farm, you will need to do all the steps manually:

1) Run the CM Form to create the database
2) Add registry edits to all web front ends
3) Add web.config edits to all web front ends

Em0Smoky,

The error you have above certainly looks like a web.config error. I would revisit the document. Also check to make sure the registry edits were made.
Mar 24, 2009 at 11:52 PM
AdApA, I had this problem as well. I did the following in order to remedy it:
Run regedit
Go to HKEY_LOCAL_MACHINE\Software\Microsoft
Create a new key under Microsoft, call it SLKCourseManager.
Create a new key under SLKCourseManager, call it Settings.
Then go back to central administration and re-run the configuration process for the course manager.
It returned immediately without confirmation when I didn't have these keys.  When I added the keys, it took a few seconds longer, and returned with the confirmation page.
Jun 4, 2009 at 2:22 PM

SLKCOURSEMANAGER in the registry-folder dont exist

and onclick of plan and assign i get this message An error occurred during the processing of . Unknown server tag 'asp:ScriptManager'.

 

can anybody can help me........

 

Regards

amit.

Coordinator
Jun 5, 2009 at 9:47 AM

For some reason the installation did not put the AJAX configuration values in web.config, so you'll have to do it manually. Try having at look at this http://geekswithblogs.net/influent1/archive/2007/05/16/112544.aspx.

Jun 5, 2009 at 9:58 AM

Hi,

have the same problem as amitthakur, search the registry and found Axelerate.SlkCourseManagerLogicalLayer under HKLM\Software\Microsoft\Fusion\GACChangeNotification\Default

Have added/verified all the web.config posts apart from

<font size="2">

<controls>

</font>

<add namespace="System.Web.UI.WebControls" tagPrefix="asp" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" /> <add namespace="System.Web.UI" tagPrefix="asp" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" /> </controls>

and

 

<appSettings>

<add key="AzmanApplication" value="MyApplication" />
<add key="AzmanStore" value="msldap://CN=AZMAN DEMO2,CN=Program Data,DC=guayabo" /> 

</appSettings>

Still can't access the Plan and Assign.aspx page to complete the installation according to SLK Course Manager Installation Guide

Any ideas?

/anders

 

 

Jun 5, 2009 at 11:20 AM
Thanks richardwillis,

That link work fine for me..

But i have one more issue, i have been able to add ( Course Manager Pages & Monitor and Assess) webpart through administrator. but it telling me that you are not instructor.

But when i logged in as instruction it giving me the sharepoint error (An unexpected error has occurred.)

I am unable to figure out what is going wrong.

Regards,

Amit.

 

On Fri, Jun 5, 2009 at 2:17 PM, richardwillis <notifications@codeplex.com> wrote:

From: richardwillis

For some reason the installation did not put the AJAX configuration values in web.config, so you'll have to do it manually. Try having at look at this http://geekswithblogs.net/influent1/archive/2007/05/16/112544.aspx.

Read the full discussion online.

To add a post to this discussion, reply to this email (SLK@discussions.codeplex.com)

To start a new discussion for this project, email SLK@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com




--
Thanks & Regards,

Amit Thakur
Software Developer
Aims Digital Services Pvt. Ltd.
91-20-2545-2041
91-99223-73260
www.aimsdigital.com
Dec 3, 2009 at 1:41 AM
amitthakur wrote:
Thanks richardwillis,

That link work fine for me..

But i have one more issue, i have been able to add ( Course Manager Pages & Monitor and Assess) webpart through administrator. but it telling me that you are not instructor.

But when i logged in as instruction it giving me the sharepoint error (An unexpected error has occurred.)

I am unable to figure out what is going wrong.

Regards,

Amit.

I am having the same exact issue.  Did you resolve it?

Dec 3, 2009 at 4:19 PM
Edited Dec 3, 2009 at 4:58 PM

It seems that the Course Manager Admin is not creating any registry values nor is it creaing ant tables in the database.  It did however create a database with the name I specified but there is nothing in it.  I manually added a key to the registry in hopes that it would generate but I have had no luck.

** EDIT **

Ok so I manually added the sql tables from the source code.  I still have no idea how to get the proper registery keys in place.  Could someone post what they have?

Dec 4, 2009 at 2:20 PM

Amit,

The CourseManager registry keys get created in the same routine that creates the database. If the database creation fails, the creation of the registry entrys fail as well. There are two REG_SZ entries created as below. Where "xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx" is the GUID you'll find in the Web.Config / AppSettings - as WebSiteGUID. If I remember properly that one gets added before the SQL failures... If there's no WebSiteGUID entry then try step 2 below...

Step 1... Create two keys at HKLM\Software\Microsoft\SLKCourseManager\Settings

SLKCMxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
Sharedxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

The values of these entries will be identical - similar to the below.. With the Data Source and Initial Catalog entered that you have now created manually.

Data Source=SQLSERVERNAME_OR_IPADDRESS;Initial Catalog=COURSEMANAGERDATABASENAME;Integrated Security=SSPI;Timeout=120
Data Source=SQLSERVERNAME_OR_IPADDRESS;Initial Catalog=COURSEMANAGERDATABASENAME;Integrated Security=SSPI;Timeout=120

Step 1... Eliminate the underlying error ...

a) Finally - to get the database to create properly via Central Admin you can also try adding the file "c:\cmupdate.txt" to the ROOT level on your SharePoint machine C Drive. One of the two failure modes is that the service process does not have permissions to create a file on the ROOT level of the C drive. The install process creates a temporary file there (don't know why they didn't code the TEMP or other location... but....)

Copy the file a file CourseManager\InstallerHelper\Installer\Solution\Filees\Solution\CourseManagerDBSchema.sql to the ROOT level of C and rename it to - "c:\cmupdate.txt". Then use Central Admin\Application Management\ Configure Course Manager again to configure your Database Server and Database name. Be sure to choose the right Site Collection...   

b) The second most common failure is that the service process doesn't have rights to the SQL server - be sure the Sharepoint AppPool account has rights to the SQL Database.

Butch

 

 

 

Dec 4, 2009 at 5:33 PM

I tried the above thing but it still did not work.  When I run the manager admin it does not modify my web.config.  I had to modify it manually from what is in the user guide.  I do not know how to get my GUID for my site to complete the configuration of this.  It is creating the databases just fine but that is it...