Support for SharePoint 2013

Topics: Developer Forum, Project Management Forum
Nov 5, 2012 at 1:12 PM

I installed SLK to SP2013 preview just to check would it work or not. Configuration tool apparently has a reference to an assembly of version 14... I got reference errors instead of configuration tool.

So, can I expect SLK for SharePoint 2013 at somepoint? Do you have already scheduled plans?

Best Regards,

Tuomas Viskari

Nov 20, 2012 at 10:51 AM

I am also looking to deploy this to SP 2013. It would be good to hear if there are any plans to make this possible and if so, what the timescales are likely to be so we can decide on whether we are looking at SP 2010 or SP 2013 for our deployment.

Thanks

Martyn

Nov 27, 2012 at 12:02 PM

Works on SP2013, I have tested it:)

BUT, I need to make some changes so I downloaded the sourcecode, 1.5.2. 2010. It is building correct now but after I deploy it I get an exception in the browser stating that "Could not load type 'Microsoft.SharePointLearningKit.Localization.LocalizationManager' from assembly 'Microsoft.LearningComponents, Version=1.3.1.0, Culture=neutral, PublicKeyToken=24e5ae139825747e'." Why?!?!

One more question, why do I have both the slkdll.snl and slkApp.sln solutions? Which of these should I be modifying when I make changes to the code?

 

Nov 29, 2012 at 9:23 AM

Thanks mariheg, that's good to know that it will work on SP2013. 

Did you have to make any changes in order to get it working on 2013?

Nov 29, 2012 at 9:25 AM

I copied all the slk files from 14-hive to 15-hive but that's about it

Coordinator
Nov 29, 2012 at 10:18 AM

I've not had a chance to look at it on SharePoint 2013 yet, but as a farm solution it probably only needs rebuiliding to reference the 2013 dlls and .net 4. If you do that it would be best to use the latest source code as there's loads of bug fixes and new features in that compared to 1.5.

I'm looking to try converting to an app architecture as well, aiming for completion by April. This may not happen depending on workload.

Richard

SLK Coordinator

http://blog.salamandersoft.co.uk

Dec 4, 2012 at 5:16 PM

I was in the process of building some workflows and analytics for SLK when 2013 came out. When the SLK didn't run on 2013 I wanted to jack up the logging level to see where it was actually failing. Look what I found under monitoring:

 

Education:
Academic Library
Administration
Change Puller
Data Access Layer
Data Aggregation
Lync Integration
Notifications
Presentation Layer
Provisioning
Quiz
Unified Data Warehouse

 

I can't find anything about how this is supposed to all wire up. Especially the presentation - (SCORM?): It almost looks like the Microsoft SharePoint Classroom has been brought back after a 7 year absence.

 

Coordinator
Jan 4, 2013 at 7:44 AM

Various people, including myself and Bjørn Furuknap have blogged about this in the Beta timeframe. However, as of RTM there has been no official documentation or mention about it which means one of 2 things:

1.    It didn't make the final feature cut, and will not be released.

2.    There's more work to be done and it will be added in a future minor release e.g. a service pack.

In either case it's not going to be officially supported at the moment.

Richard

Jun 7, 2013 at 7:02 PM
Just wanted to leave feedback that I'm interested in seeing this made available for 2013 as well. It's a great product that we use here.
Jun 11, 2013 at 1:41 PM
I don't know if it can help, what i did it's :
  • recompile the last version ( 1.7) , build :76e03b03897a
  • Changing the entire project with .NET 4.5
  • doing a msbuild
  • deploying the package
  • fixing problems with App Fabric (for the cache)
  • fixing problems with the the Hive 15 and 14 ( copy 14 to 15)
    then it's working but there is a bug concerning the CSS of the differents layouts
Jul 5, 2013 at 12:08 PM
nabilbabaci - please can you upload your project with the above fixes in?
Oct 11, 2013 at 1:46 PM
sharepointpersonX wrote:
nabilbabaci - please can you upload your project with the above fixes in?
And the whole installation process if possible because I can imagine it's quite different from the one described in Readme.txt. I changed all projects from Visual Studio 2008 to 2012 and target framework from 2 to 4.5, but I don't see any makefile for the rebuild process. Moreover the latest build is df0ae3822c18 and not 76e03b03897a.
Coordinator
Oct 20, 2013 at 8:02 AM
I've got a couple of schools testing the SP2013 version of SLK now, so I should be able to release soon.
Oct 21, 2013 at 7:41 AM
Awesome!

Is it SharePoint App style of application or is it full trust solution?
Coordinator
Oct 21, 2013 at 5:31 PM
Full trust.
Oct 30, 2013 at 4:56 PM
Hi Richard,
Any word on the SLK version release for Sp 2013?
Coordinator
Oct 31, 2013 at 10:01 AM
Hoping next week.
Nov 1, 2013 at 3:06 AM
Thank You. This is exciting news.
Nov 2, 2013 at 7:54 PM
THAT WOULD BE AMAZING!!! I have been anxiously waiting for SLK 2013!!!
Nov 7, 2013 at 9:23 PM
Hi Richard,
Just checking in with the progress :) Any Updates.

-Sai
Coordinator
Nov 8, 2013 at 9:12 AM
It's not the end of the week yet!

Just a couple of minor cosmetic issues to resolve, but I will put up today.
Coordinator
Nov 9, 2013 at 6:23 AM
Nov 14, 2013 at 5:44 AM
Hi Richard,

I have downloaded the SLK 1.7 version for SLK 2013.. 2013 folder is there but the installation steps are not mentioned for SharePoint 2013... only SharePoint 2010 or SharePoint 2007 steps are mentioned in the 2013/installation.txt folder .. Can you please help me with the steps to use SLK for SharePoint 2013??

-- Amit
Coordinator
Nov 14, 2013 at 10:05 AM
Should be the same as for 2010.
Nov 15, 2013 at 3:46 AM
Edited Nov 15, 2013 at 3:47 AM
Thanks Richard, but In the SP 2010 and 2007 folder we have 2 additional installation files like AddSolution.ps1 or AddSolution.cmd (depending on whether for SharePoint 2007 or SharePoint 2010) but we don't have these files exists in the 2013 folder then Is that means we should skip the steps related to the mentioned files available for SP 2010?? and start installation with the other existing SP 2010 steps.
Nov 20, 2013 at 7:19 AM
Hi Richard, I just want to know the details of the above mentioned questions to use SLK in SharePoint 2013...
Can you please confirm?
Coordinator
Nov 27, 2013 at 9:18 AM
The install is exactly the same as for 2010, you can just copy the scripts for the 2010 folder.

Thanks for the report I'll bundle the scripts in the folder for the next release.

Richard
Nov 27, 2013 at 9:49 AM
Thanks Richard...


Regards
Amit Patil

Sent from my Samsung Galaxy Grand



Nov 27, 2013 at 8:04 PM
Richard,

Thank you so much for bringing forth the 2013 version. Would you compile and upload a new solution package to include up to todays patches?

Thanks!!

Charles Babcock
Nov 28, 2013 at 4:17 AM
Yes Richard... we will install on SharePoint 2013 but not now maybe after some days or 1 month.


Regards
Amit Patil

Sent from my Samsung Galaxy Grand



Nov 28, 2013 at 4:26 PM
I will install after the new compile is posted.

Thanks!!

Charles Babcock
Dec 9, 2013 at 5:07 PM
Hey guys,

I am trying to build and deploy SLK to SharePoint 2013 (.NET v4.5) using a Visual Studio 2012 environment. I have been able to get the solution at "..\SLK\Slk\Dll\SlkDll.sln" to compile and deploy properly after updating the projects for use in VS2012. I have also been able to run msbuild in "..\SLK\Slk\Solution" and get the created wsp file deployed into my farm and running on a site collection. The only problem I'm running into now is trying to get the solution at "..\SLK\Slk\App\SlkApp.sln" to build and then deploy.

How do I get this solution to compile and then deploy?

mariheg wrote:
why do I have both the slkdll.snl and slkApp.sln solutions? Which of these should I be modifying when I make changes to the code?  
From what I've been able to gather the SlkDll.sln contains the backend code for the .aspx pages in SlkApp.sln.


nabilbabaci wrote:
I don't know if it can help, what i did it's :
  • recompile the last version ( 1.7) , build :76e03b03897a
  • Changing the entire project with .NET 4.5
  • doing a msbuild
  • deploying the package
  • fixing problems with App Fabric (for the cache)
  • fixing problems with the the Hive 15 and 14 ( copy 14 to 15)
    then it's working but there is a bug concerning the CSS of the differents layouts
Nabilbabaci, which project did you run msbuild on? Also if possible, could you please provide some more details and maybe upload the project with your fixes included somewhere? Thanks.
Dec 25, 2013 at 11:41 PM
Richard,

Would you post an updated build? I want to try a new demo.

Kind regards,

Charles
Coordinator
Jan 2, 2014 at 9:42 PM
Hi Charles,

The one at http://www.salamandersoft.co.uk/downloads/slk17.zip should always be the latest.

Richard
Jan 3, 2014 at 9:20 PM
Is there a way to know the build date, Richard? Or do you update this with every patch?
Coordinator
Feb 12, 2014 at 4:54 PM
Not currently, I try to update this with all patches, or at least the ones which affect my customers.