Problems with .gif files in SP2013

Topics: Developer Forum, User Forum
Mar 14, 2013 at 11:13 AM
Anyone knows why .gif files in a scorm-package won't display in ie? I am on a Windows Server 2008 R2 Enterprise with SharePoint 2013. In Firefox everything is working as a charm.

Any hints or clues is highly appreciated :)

Marit
Coordinator
Mar 27, 2013 at 10:01 AM
Does it work in SharePoint 2010?

Richard
SLK Coordinator
http://blog.salamandersoft.co.uk
May 1, 2013 at 5:18 PM
Was this ever resolved? I am running into the same issue on SharePoint 2013 also. The images from the Solitaire sample load in Chrome but not in IE.

Any suggestions?
May 1, 2013 at 9:19 PM
Jepps, this one was really tricky. We ended up making a custom httpmodule that said that files ending With .gif is of content type image....
Coordinator
May 7, 2013 at 12:28 PM
Try editing slksettings.xml to explicitly set the mime type e.g. the current settings for jpeg are

<MimeTypeMapping Extension=".jpe" MimeType="image/jpeg" />
<MimeTypeMapping Extension=".jpeg" MimeType="image/jpeg" />
<MimeTypeMapping Extension=".jpg" MimeType="image/jpeg" />

so you could add

<MimeTypeMapping Extension=".gif" MimeType="image/gif" />

Richard
SLK Coordinator
http://blog.salamandersoft.co.uk
May 7, 2013 at 5:32 PM
Edited May 8, 2013 at 10:14 AM
That worked Richard, thanks!

When I built and deployed the solution with the modified slksettings.xml file and configured the site collection it didn't work, but when I went back in and re-configured the site collection specifying the modified slksettings.xml file it worked.

I'm assuming default slksettings are used when the file is not specified during configuration?
Coordinator
Jun 7, 2013 at 4:38 PM
Yes, the default slksettings are only used when the file is not specified during configuration. The settings are then saved into the SLK database, and must then be explicitly updated for changes to take effect.