'UserItemSite' not found in the schema.

Topics: Developer Forum
May 8, 2013 at 3:34 AM
Edited May 8, 2013 at 3:38 AM
Hi, I have downloaded SLK 1.5 Source Code. I rebuild it using MSBuild without changing any of the code yet, but when i deployed it. It gives me an error on the Create an Assignment Page (AssignmentProperties.aspx).

Here's the log regarding this error.

SharePoint Learning Kit Error
System.InvalidOperationException: Item type 'UserItemSite' not found in the schema.
at Microsoft.LearningComponents.Storage.LearningStoreJob.AddOrUpdateItem(String itemTypeName, IDictionary2 uniquePropertyValues, IDictionary2 propertyValuesToUpdate, IDictionary2 propertyValuesForAdd, Boolean requestItemId)
at Microsoft.LearningComponents.Storage.LearningStoreJob.AddOrUpdateItem(String itemTypeName, IDictionary
2 uniquePropertyValues, IDictionary2 propertyValuesToUpdate)
at Microsoft.SharePointLearningKit.SlkStore.AssignUserItemIdentifier(IEnumerable
1 users)
at Microsoft.SharePointLearningKit.SlkMemberships.FindAllSlkMembers(SPWeb web, ISlkStore store, Boolean instructorsOnly)
at Microsoft.SharePointLearningKit.ApplicationPages.AssignmentPropertiesPage.PopulateSlkMembers()
at Microsoft.SharePointLearningKit.ApplicationPages.AssignmentPropertiesPage.get_SlkMembers()
at Microsoft.SharePointLearningKit.ApplicationPages.AssignmentPropertiesPage.DisplayAssignmentProperties()
at Microsoft.SharePointLearningKit.ApplicationPages.AssignmentPropertiesPage.OnPreRender(EventArgs e)
May 8, 2013 at 6:30 AM
just run upgrade16.sql in the source code. ^_^