Unable to play mp4 videos in IE 9 from SLK

Topics: Developer Forum, Project Management Forum, User Forum
May 29, 2013 at 11:25 AM
Hi,

I have a SCORM content that contains HTML5 based content, few mp4 video and mp3 audio files embedded in the content.

When I play the content using IE 9 , the mp4 video does not play. I am using IIS 7.5 and sharepoint 2010, however when I play this content using google chrome through SLK there are no issues, the content plays normally.
Also locally this content is playing on IE 9.

We have already set the MIME type for .mp4 at the server.

Can you please advice, on how to resolve this issue

Regards,

Aditi.
Coordinator
Jun 7, 2013 at 4:36 PM
Hi Aditi,

Try setting the mime type in the slksettings.xml file under SharePoint Learning Kit Configuration in Central Administration.


Richard
SLK Coordinator
http://blog.salamandersoft.co.uk
Jun 9, 2013 at 11:09 AM
Hi Richard,

This worked, the content is now playing seamlessly in IE9.

Many Thanks for your help.

Regards,
Aditi.
Jun 11, 2013 at 1:58 PM
Hi Richard,

We are facing the same issue on Safari browser on IPAD and MAC, is there anything addtional we need to set for Safari browser?

mp3 and mp4 content works locally but does not play through the server

Regards,
Aditi
Jun 17, 2013 at 10:19 PM
Edited Jun 17, 2013 at 10:19 PM
Hi Richard,

I am also having the same issue using the basic webplayer ie content plays ok in chrome but no other browser any suggestions please

Kind Regards

Gary
Jun 20, 2013 at 10:40 AM
Hi has anybody solved the problem with mp4 videos not playing on IPAD
Coordinator
Jun 24, 2013 at 9:13 AM
Have you tried setting the mime type in the slksettings file?
Jun 24, 2013 at 9:20 AM

Hi Richard,

Yes I have added video/mp4 mime-type to the XML file, and the content plays on all pc browsers with no issue. However on the IPAD and the android pad the video will not play through the course player but will play if I go directly to the course index file, very frustrating and of course plays perfectly from the SCORM cloud.

Can you think of any other mime-types that may be missing from the slksetting xml file that the IPAD is looking for

Kind Regards

Gary

Jun 24, 2013 at 9:48 AM
Hi Richard,

I am facing the same issue, have set the MIME type in the slk settings and the content plays on all PC browsers.
But on IPADs and android the video and audio wont play through the SLK player.

Is there any browser compatibility setting in SLK we need to turn on?

Regards,
Aditi.
Jun 24, 2013 at 4:56 PM
Hi Richard,

I have been writing a httphandler for mp4 which for some reason do not get called from with in the frameset, the handler is called when accessing the course directly. any ideas on this on.

I think the problem with the videos on the idevices is that the header does not contain Accept-Ranges bytes may be barking up the wrong tree though :-)

Kind regards

Gary
Coordinator
Jun 25, 2013 at 12:04 PM
Can you try setting ELearningIisCompatibilityModeExtensions in slkSettings.xml to include mp4. The default is:
ELearningIisCompatibilityModeExtensions="mp3, swf"
Worth a go.

Richard
Jun 25, 2013 at 12:18 PM

Hi Richard,

Have already tried that with no success

Gary

Aug 20, 2013 at 7:01 AM
Hello Richard / Gary,

Were you able to resolve the issue with audio and video files playing on IPAD's , we are still stuck with this problem.

Regards
Aditi.
Aug 20, 2013 at 9:46 AM

Hi Aditi

I have resolved it for my own installation you will need to implement a custom http handler, the problem is that idevices expect byte-ranges, the frameset writes its own headers thus bypasses the normal IIS operation. I use the Basicwebplayer implementation which has been heavily customised and as such my solution will not be of much use for you. I have however sent Richard our code which could potentially be used as a starting point for a solution to the SharePoint installation

Regards

Gary

Aug 29, 2013 at 6:24 AM
Thanks for your reply Gary, would it possible for you to share your code with us so we may try to reuse your solution and customize it to solve the issue we are facing.

Regards,

Aditi.
Sep 2, 2013 at 9:07 AM

Hi Aditi

Sure if you send me your email address via the ‘contact me’ on my profile I’ll sort something out for you

Regards

Gary

Coordinator
Oct 20, 2013 at 8:28 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.