Course manager status

Mar 5, 2009 at 4:48 PM
I've installed SLK 1.3.1 and all is good.. I tried to install the Course Manager and received the following error;

ERROR: SLK Version 1.3.1 is not installed.

ERROR: Course Manager could not be installed correctly.


Any thoughts ?

Thanks
Gerald
Mar 5, 2009 at 6:31 PM
*** UPDATE ***

I was able to manually get Course Manager installed, with the following commands... 

stsadm -o addsolution -filename files\Course_Manager_Configure.wsp
stsadm -o deploysolution -name Course_Manager_Configure.wsp -url http://yourtestsite.yourcompany.com -immediate -allowGacDeployment -force
stsadm -o execadmsvcjobs
stsadm -o activatefeature -name Course_Manager_Configure -url http://yourtestsite.yourcompany.com -force

now, despite the erroneous previous error that SLK 1.3.1 wasn't installed the solution is still looking for SLK 1.3.0.2 see error below;

Event Type: Failure Audit
Event Source: Windows SharePoint Services 3
Event Category: General
Event ID: 6763
Date:  3/5/2009
Description:
SafeControl load exception:CourseManagerConfCs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f1391ddb6ea1ca6b Exception: Could not load file or assembly 'Microsoft.SharePointLearningKit, Version=1.3.0.2, Culture=neutral, PublicKeyToken=24e5ae139825747e' or one of its dependencies. The system cannot find the file specified.

--Thanks
Gerald

Mar 13, 2009 at 9:17 PM
Edited Mar 13, 2009 at 9:29 PM
The same here!

Tried it also with "1.3.1" instead of "1.3.0.2" in installer.bat, SolutionsAndFeaturesTest.exe 1.3.0.2 3.5.0.0 %1

As mentioned in "reviewing assignments..." the "installation" via those batch-files is rather inflexible and perhaps not ment for international use.
Mar 15, 2009 at 3:45 PM
I thought that I had read somewhere in this discussion an updated version of Course Manager for 1.3.1 had been created and posted, but apparently not.

Richard, perhaps the Course Manager download should be removed from the 1.3.1 Release download page until this is done? It seems to be causing a lot of confusion for users.
Coordinator
Mar 19, 2009 at 4:18 AM
Hi,

HaroldPGray has uploaded a patch to resolve this. I'm hoping to integrate it within a week.

Richard
SLK Co-ordinator
http://blog.salamandersoft.co.uk