New Release

Coordinator
Apr 3, 2009 at 11:38 AM
I've just created a new release SLK-1.3.2-20090403.zip on the 1.3.2 Development Builds release page.

This contains the first release of the work that ITWorx is doing and is the first step to 1.4. It covers:

Firefox support
Teacher Review
LRM on 64 bit

I've given it a quick sanity check and all appears to be working although I haven't tried LRM on 64 bit.

I'm just about to upload the source code as well. I've had a look through the code and there doesn't seem to be any problems there. In fact it's remarkably similar to the patch for Firefox I posted right down to the comments.

The only change I've made to the code is that I've stripped out the change comments in it. In my opinion these should not go in code, that's what a source code control system allows you to do.

Richard
SLK Co-ordinator
http://blog.salamandersoft.co.uk
May 28, 2009 at 3:02 PM

Good Afternoon,

After upgrading to 1.3.2, there is still no solution for the teachers review bug.

I even deleted the whole Sharepoint Learning Kit and installed it back on the Team Site.
And still no solution.

I'm using Articulate Quizkmaker...
My conclusion: Or the new build isn"t giving a solution, or i'm doing something wrong... 
Someone else who tested this release already?
 

Jeroen
IT Consultant
Konvert Interim

May 28, 2009 at 10:55 PM
Edited May 28, 2009 at 10:55 PM

Hi!

We use the Class Server learning resource editor to create our e-learning lessons as ims-files. We use this editor offline  - without a running Class server - in a Windows XP virtual machine. With the created files there is no teachers review bug. Both, teachers and students can review the answers. Students can also see the right answers if the teacher has selected this option when submitting the questions.

One problem is, that students have to take care to save their answers "in the right way" - after every saving the answering window (IE) or answering register (Firefox) has to be closed immediately and has to be reopend by selecting "Resume assignment". Without closing all further answers will be lost. Our MOS 2007 ist behind a ISA 2006, only reachable by https. Maybe the AAM (alternate access mapping) on the MOS 2007 causes this problem. 

Helmut
Vienna, Austria

Coordinator
May 29, 2009 at 12:18 AM

Hi Jeroen,

Can you post up a package you've created which has this problem.

Richard

SLK Co-ordinator

http://blog.salamandersoft.co.uk

May 29, 2009 at 8:01 AM

Hi,

I dont find any place here where i can upload the file.
Can you please help me to upload the file here?

thx in advance

Jeroen, Belgium
IT Consultant
Konvert Interim

Coordinator
May 29, 2009 at 9:35 AM

Hi Jeroen,

You can upload files on the Upload Patches page under Source Code.

http://slk.codeplex.com/SourceControl/UploadPatch.aspx

 

Richard

 

 

May 29, 2009 at 10:02 AM

Hi Richard,

We have uploaded a sample quiz created in Articulate Quizmaker (studio 09) and exported to Scorm 2004 v3.

ID = 2965

Best regards,

Jeroen (and Koen)

Jun 12, 2009 at 1:41 PM

Hi Richard,

I have investigated this problem a little further. I have uploaded all the information you need to the Patches directory.

You will find a zip-file which contains a word 2007 document with a description of the problem we are facing, and with all the steps / screenshots. I have also included the debug stream between the course package and the LMS by setting the SHOW_DEBUG_ON_LAUNCH to true in configuration.js (in the lms directory of the course package).

Below you find part of the debug stream (debug-2.start review.txt). There is an error related to the GetValue method. It looks to me that this error is related to our problem.

................................................................................Calling Commit
111:Fri Jun 12 10:33:31 UTC+0200 2009 - strResult=true
112:Fri Jun 12 10:33:31 UTC+0200 2009 - Returning true
113:Fri Jun 12 10:33:31 UTC+0200 2009 - In GetDataChunk
114:Fri Jun 12 10:33:31 UTC+0200 2009 - In ClearErrorInfo
115:Fri Jun 12 10:33:31 UTC+0200 2009 - In IsLoaded, returning -true
116:Fri Jun 12 10:33:31 UTC+0200 2009 - In SCORM2004_GetDataChunk
117:Fri Jun 12 10:33:31 UTC+0200 2009 - In SCORM2004_ClearErrorInfo
118:Fri Jun 12 10:33:31 UTC+0200 2009 - In SCORM2004_CallGetValue strElement=cmi.suspend_data
119:Fri Jun 12 10:33:31 UTC+0200 2009 - In SCORM2004_GrabAPI
120:Fri Jun 12 10:33:31 UTC+0200 2009 - Grab API, returning, found API = true
121:Fri Jun 12 10:33:31 UTC+0200 2009 - Call GetValue
122:Fri Jun 12 10:33:31 UTC+0200 2009 - strResult=
123:Fri Jun 12 10:33:31 UTC+0200 2009 - intSCORM2004Error=403
124:Fri Jun 12 10:33:31 UTC+0200 2009 - Detected failed called to GetValue
125:Fri Jun 12 10:33:31 UTC+0200 2009 - In SCORM2004_SetErrorInfo
126:Fri Jun 12 10:33:31 UTC+0200 2009 - intSCORM2004Error=403
127:Fri Jun 12 10:33:31 UTC+0200 2009 - strSCORM2004ErrorString=Data Model Element Not Initialized
128:Fri Jun 12 10:33:31 UTC+0200 2009 - strSCORM2004ErrorDiagnostic=The data model element cmi.suspend_data is not initialized.
129:Fri Jun 12 10:33:31 UTC+0200 2009 - Error calling LMSGetValue:
130:Fri Jun 12 10:33:31 UTC+0200 2009 - strElement=cmi.suspend_data
131:Fri Jun 12 10:33:31 UTC+0200 2009 - Error Number=403
132:Fri Jun 12 10:33:31 UTC+0200 2009 - Error String=Data Model Element Not Initialized
133:Fri Jun 12 10:33:31 UTC+0200 2009 - Diagnostic=The data model element cmi.suspend_data is not initialized.
134:Fri Jun 12 10:33:31 UTC+0200 2009 - Returning

 

Since this is the only 'BUG' which keeps us from using the sharepoint learning kit in our live environment, I hope we can find a solution soon.

Best regards,

Koen

Coordinator
Jun 13, 2009 at 7:40 PM

Thanks Koen, that gives me something to work with. I'll try and look at it this coming week.

Richard

Jun 15, 2009 at 8:42 AM

Hi Richard,

Underneath you will find the response from Articulate Support (and it works). I hope this can help someone else.

I do not like the resume dialog box though, but this is an Articulate issue.

Best regards,

Koen

"

Hi Koen,

 

Thanks for submitting the zipped file.  This makes the issue easier to diagnose.

 

After reading through all of the documentation, here's what you'll need to do to enable the review feature for the quiz:

 

First, you need to enable the resume feature for the quiz.  The '09 line of products works differently than the legacy products.  In the legacy products, if you wanted to have your LMS handle resume, you would disable it in the Articulate software.  With the '09 software, you have to enable the resume feature within Quizmaker for the resume feature to work correctly.  Without the resume feature enabled, the quiz will always launch like a new attempt.

 

Second, you need to enable the review quiz feature of the pass and fail slides.  To do this, open your quiz in Quizmaker, click on the Pass or Fail Result slide, checkmark the Review Quiz option.  This will allow the quiz to be reviewed.

 

======

 

Now, with the options enabled above, here's the workflow that your student will see:

 

1.  Login to the LMS and take the quiz

2.  Upon passing or failing the quiz, they will be met with a slide that has a button for "Review Quiz".  They can either click on the Finish button on that same slide or just review the quiz 3.  The next time the quiz is accessed, they will be met with a notification window that states:

 

Would you like to resume where you last left off?  Yes or No

 

If the user clicks Yes, then they will be sent to the quiz result slide that contains the button for Review Quiz.  They can review the quiz by clicking on that button.

 

If the user clicks No, then the quiz is treated like a new attempt and the quiz will start over.

"

 

Jun 17, 2009 at 1:16 AM

Hi Richard,

Do you have a tentative date for the elevation of the V1.3.2 development builds to V1.3.2 general release (stable)

Thanks

Craig Tucker

 

 

Coordinator
Jun 30, 2009 at 2:43 AM

Hi Craig,

I'm waiting for the IT Worx Drop Box work before any more general releases. This will raise the version to 1.4.

It should be available next week.

Richard

SLK Co-ordinator

http://blog.salamandersoft.co.uk

Jul 7, 2009 at 12:07 PM

Hi Richard

We have tested 1.3.2 the latest development build.  We still find it is impossible to Review assignments. 

We are a bit confused whether the problem is with the SCORM authoring tool that we are using or is it the SLK.  We can see a different parameter is sent to play the SCORM file with the 2 operations.  Therefore, it has made us speculated that the SCORM file needs to be authored with 2 modes.

Is this the correct concept on how it is suppose to work?

Does anyone have a SCORM file that works with SLK in Review mode for 1.3.2?  Which SCORM authoring package have they used?

Thanks

 

 

 

Coordinator
Jul 7, 2009 at 3:55 PM

It does depend on your authoring tool supporting Review mode. Which tool are you using.

Although SCORM is a standard, almost every different tool has a different understanding of how it works and which bits they have implemented.

 

I know of packages which work in review mode. Hunterstone tested Thesis with the latest release and said that the review mode worked.

Richard

Jul 8, 2009 at 11:17 AM
Edited Jul 8, 2009 at 12:43 PM

Hi Richard

I just ran a test with Thesis from Hunterstone.  I created a simple quiz with feedback.  Unfortunately saving it in any SCORM.zip format (1.2, 2004, 2004 Third), when reviewing the quiz, the expected feedback did not appear in review mode on the latest SLK install. 

Is there a test file that you have that was done with Thesis that shows this working or are you currently aware of this and working on the 1.4 release.

I wondering whether there may be an issue with the Upgrade.  I followed the upgrade instructions and every step went fine and I even cleared out the database and recreated it.  However, in the global assembly, I still see the version of Microsoft.SharepointLearning Kit to be 1.3.0.2 rather than 1.3.2. 

Therefore, is it the upgrade that has went wrong?  Which version number do you see? 

Thanks

Jul 9, 2009 at 9:57 AM

A bit of further testing with Thesis, if we select the "Include Reporting" property for the assignment,  the feedback/review comes immediately after the student has completed the course which is not necessary a bad thing. There seem to be no way of controlling whether the feedback is presented only when the assignment is opening in review mode.

Is this expected behaviour?

Thanks

 

Jul 9, 2009 at 3:00 PM
Edited Jul 9, 2009 at 3:12 PM

It should show version 1.3.2 in the GAC. We have seen problems upgrading to 1.3.2 before, and ended up completely uninstalling and reinstalling to get it installed properly. HunterStone THESIS has been tested with SLK-1.3.2-20090403 and SLK-1.3.2-20090630 and review mode as teacher/instructor works for these versions.