SLK 1.7 on SP2007

Topics: Developer Forum
Apr 4, 2014 at 2:01 AM
Cannot install 1.7 on SP2007 due to the CommandUIExtension present in the SharePointLearningKit\elements.xml file (2007 does not have a ribbon).

Error message:
Feature definition with Id 00057002-c978-11da-ba52-00042350e42e failed validation, file 'SharePointLearningKit\elements.xml', line 27, character 22: The element 'CustomAction' in namespace 'http://schemas.microsoft.com/sharepoint/' has invalid child element 'CommandUIExtension' in namespace 'http://schemas.microsoft.com/sharepoint/'. List of possible elements expected: 'UrlAction' in namespace 'http://schemas.microsoft.com/sharepoint/'.
Apr 8, 2014 at 2:39 PM
I have the same error. Have you solved ? Someone else ?

Thanks in advance !
Jun 5, 2014 at 8:43 AM
Same error! help pls !
Jun 17, 2014 at 4:26 PM
I too have this error. Does anyone have a solution?
Coordinator
Jun 23, 2014 at 2:59 PM
Please download the updated version at http://www.salamandersoft.co.uk/downloads/slk1.7.1.zip and see if that fixes it for you. If so I will promote it to the recommended release.

Regards,
Richard
SLK Coordinator
Aug 20, 2014 at 7:51 AM
Edited Aug 20, 2014 at 11:46 AM
slk1.7.1.zip corrupted, can upload again?

Please ignore this message. I upgrade to sharepoint 2013 with slk 1.7 working fine.