Do i need to reconfigure SLK Database after Downgrade from SLK 1.7 to SLK 1.5

Topics: Developer Forum, User Forum
May 20, 2014 at 2:36 AM
Edited May 20, 2014 at 2:42 AM
Hi,

I have upgraded the SLK from 1.5 to 1.7. We are using third party product that use SLK and support SLK 1.5 version so I have to downgraded it to SLK 1.5. My Question is do i have to reconfigured the SLKDatabase again for the same SiteCollection or There will be no database change required as suggested in the “upgrade.txt”.

Regards,
Nik
Coordinator
May 29, 2014 at 7:58 AM
To upgrade from 1.5 to 1.7 you will have needed to run the upgrade script for 1.6. This will need to reversed. The table changes should be OK, but the schema value in the configuration table definitely needs to go back to version 1.5. The function changes may or may not work without being rolled back – I’ve never tried it.

Richard
SLK Coordinator
http://blog.salamandersoft.co.uk