Upgrading from SLK 1.5 to 1.7

Topics: Developer Forum, Project Management Forum, User Forum
Jun 14, 2014 at 4:02 AM
Edited Jun 14, 2014 at 9:07 PM
I just finished upgrading from SLK 1.5 to 1.7.

Now, I am getting errors when trying to begin any assignment:
The assignment (ID 238) does not exist or you may not have permission to access it.

Also errors when trying to assign an assignment.
An error occurred. More information may be available in the server event log.

Any idea how to fix this?

Event Viewer is showing this error:

SharePoint Learning Kit Error System.InvalidOperationException: Column 'AssignmentEmailChanges' not found in the view. at Microsoft.LearningComponents.Storage.LearningStoreQuery.AddColumn(String columnName) at Microsoft.SharePointLearningKit.SlkStore.BeginGetAssignmentProperties(LearningStoreJob job, AssignmentItemIdentifier assignmentId, SlkRole slkRole) at Microsoft.SharePointLearningKit.SlkStore.GetGradingProperties(AssignmentItemIdentifier assignmentId) at Microsoft.SharePointLearningKit.ApplicationPages.Grading.get_AssignmentProperties() at Microsoft.SharePointLearningKit.ApplicationPages.Grading.LoadGradingList()
Jun 15, 2014 at 1:31 PM
I found the solution. There is a update to the Learning kit database that was included in version 1.6. After running that sql update my site works!
Coordinator
Jun 23, 2014 at 3:14 PM
Yes, you need to run upgrade16.sql. I'll add that to the documentation and include in the zip file.


Richard
SLK Coordinator
http://blog.salamandersoft.co.uk