Course Manager 1.3.1-1 and multiple WFEs

Topics: Developer Forum, User Forum
May 5, 2009 at 6:57 PM
I have now installec CM 1.3.1-1 on two identical farms (SP WFE w/ Cent Admin box, SSRS SP Integrated box, and MSS(E) box) and both exhibit the same issue with CM 1.3.1-1.

A) When attempting to configure CM from the Central Admin, the database is created, however the structure isn't (IOW, there are no tables).  I can see the database is created (via the Application Event Log on the SQL Server) with the correct user account that has this ability.

B) The SQL Server name and Database name on the CM configuration for Central Admin does not save.

C) No registry entries are created on any of the WFEs to save the SQL connection string (I saw somewhere that it was supposed to do this).  Creating them manually on all WFEs does not resolve B).

===

EDIT: A) is solved by promoting the Application Pool user (in my case, a domain account) to sa.  This is unfortunate, given the same account can successfully create the SLK database along with standard SharePoint databases.  For B) and C), I see no attempt to write to the registry by the w3wp.exe process (using Process Monitor).
Coordinator
May 10, 2009 at 12:26 AM

Hi Rilex,

I imageine that B & C are going to be caused because A failed so course manager never got to that part. I've had a quick look at the source code and if any errors occur it just throws them away, so I've created a quick debug version for you to try. http://www.salamandersoft.co.uk/slk/cmdebug.zip. Upgrade that and try again and post the resulting error message.

Richard

SLK Co-ordinator

http://blog.salamandersoft.co.uk

May 11, 2009 at 5:50 PM
Edited May 11, 2009 at 6:01 PM

And here is the error:

A web configuration modification operation is already running.

 

Note that I had uninstalled CM completely, but when the web configuration is reverted, the application that did that ends up crashing.  Unfortunately I don't have the error on hand.  I did re-install, then upgraded to your version.

EDIT: Here is the error when uninstalling CM:

Restoring the Web.config...

Unhandled Exception: System.InvalidOperationException: A web configuration modif
ication operation is already running.
   at Microsoft.SharePoint.Administration.SPWebService.ApplyWebConfigModificatio
ns()
   at RestoreWebConfig.RestoreWebConfig.DeleteNode(String Direction, String Elem
entName, String ElementPosition, String Value, UInt32 Sequence)
   at RestoreWebConfig.RestoreWebConfig.Main(String[] args)
Web.config Restored Succesfully

May 11, 2009 at 5:58 PM

http://blogs.microlinkllc.com/dmcwee/archive/2008/04/07/a-web-configuration-modification-operation-is-already-running-.aspx

I do not have the ability to delete the "Config Refresh" job, and do not see the specific Timer Job they mention in the above post.

May 22, 2009 at 9:40 PM

Any new news?

Coordinator
Jun 1, 2009 at 12:39 AM

Hi Rilex,

I've uploaded a new version to try to solve the problem. It's at http://slk.codeplex.com/Release/ProjectReleases.aspx?ReleaseId=28095. Try uninstalling with that one.

Richard

Jun 1, 2009 at 5:04 PM

Same error with configurtion CM, unfortunately.  Also encountered the same issue with the web config modification when doing the uninstall.

Jun 1, 2009 at 5:17 PM

I reset IIS on all 3 boxes in the farm, deleted the CM database that the previous Configure created, and I received a new error after attempting to configure it:

 

System.InvalidOperationException: A web configuration modification operation is already running.
at Microsoft.SharePoint.Administration.SPWebService.ApplyWebConfigModifications()
at CourseManagerConfCs.ConfigurePage.BtnOk_Click(Object sender, EventArgs e)

Well, same error, but not as friendly as "A web configuration modification operation is already running." :)

Jun 3, 2010 at 11:57 PM
Edited Jun 4, 2010 at 7:56 PM

I am also getting the same behavior.  I have a single web front end, an Index/Admin server and a SQL Server 2008 backend.  All three servers are configured with Windows Server 2008 R2.  The Application Pool account is a domain account that is also sa on the SQL server.  The SLK is working fine, the initial install of Course Manager goes through without errors but when trying to configure in Central Admin I am getting the same error: 

System.InvalidOperationException: A web configuration modification operation is already running.

I have tried installing from both the WFE and the Index servers with the same results.

 

UPDATE:

The registry keys were created on the Central Admin server but not on the WFE.  Once I created the reg keys on the WFE server, it is now working.