SLK 1.7.1

Coordinator
Nov 17, 2014 at 9:50 AM
Forgot to post in here when I did it, but I released SLK 1.7.1 on 10 Nov 2014. You can download from
https://slk.codeplex.com/releases/view/137537

The notes are:

A bug fix release for SLK 1.7. The zip file contains versions for SharePoint 2007, 2010 and 2013.

Changes include:
Handle @ in a user name for drop boxes
Handle css for SCORM packages in SharePoint 2013
Fix for SharePoint 2007 solution package containing incorrect element files
Added and fixed some mime-types in slksettings.xml
Allow frameset to run in non-compatibility view in Internet Explorer
Prevent script injection in ALWP frameset

This is a recommended upgrade, especially if using SCORM packages in SharePoint 2013.

This is intended to be the last release for 1.7. All future functionality will go into SLK 1.8. I already have customers running on that, so it's just a case of deciding when to call it a day adding features to it.

Richard
SLK Coordinator
http://blog.salamandersoft.co.uk
Nov 18, 2014 at 10:06 AM
Hello Richard, we have installed SLK 1.7.1 on Sharepoint 2013 and I tried to install Slovak language pack on it. I have download it from download section for SLK version 1.3.1, globally deployed slk.wsp (1051), updated SlkSettings.xml and changed locale to Slovak. Assignment List Web Part is translated correctly but everything else is still in English. Did I miss something?

One more thing. After upgrade from 1.7.0 to 1.7.1 Scorm packages are now OK, but we still have problem with Assignment List Web Part under Internet Explorer 9, 10, 11 (other browsers are OK). It is not displayed correctly:
Image
Do you have any suggestions for this issue?
Coordinator
Nov 24, 2014 at 1:38 PM
Looks like the language packs aren't compatible with SLK 1.3.1 onwards. You can download a sk-sk one from http://www.salamandersoft.co.uk/downloads/SLK1051.zip.
Coordinator
Nov 24, 2014 at 1:40 PM
I can't duplicate the ALWP problem. Are you using a standard master page or a modified one?
Nov 25, 2014 at 1:13 PM
Thank you very much for that language pack! I am using standard non modified master page and I have tried almost everything (change of master page, edit webpart properties..), but only one thing that works is to turn on Edge mode in IE 11.