Initial SLK Permission groups

Topics: Developer Forum
Jun 4, 2009 at 7:43 PM

I'm going through the Getting started PDF.  I'm stuck because I don't know how to get the SLK Permissions to show up.

It seems that they should already be there, but when I go to grant the test users permissions, I don't see the SLK Permissions

I must have done something wrong.

Can I just create these, or do they need to be created by the configuration?

Any help would be greatly appreciated as we really want to leverage this for a client.

Thanks,

Nate

Jun 4, 2009 at 7:54 PM

Try this:

Go to Central Administration

Application Administration

Configure Sharepoint Learning Kit

SLK Permissions

Click on Create Permissions and click ok

 

Go to your site

When you add new people to the group, click on Give Permissions directly – you should see the Instructor, Learner roles.

 

Jun 4, 2009 at 7:56 PM

I did that, but I still don't see them, is it a caching issue in SharePoint?

Jun 4, 2009 at 8:04 PM

OK, I solved it.  I had configured the SLK in the wrong site, not my 80 port site!

Jun 5, 2009 at 2:05 PM

Hi there

Have installed the SLK Manager and solved the asp.skripmanager error, displayed and added the web parts to the page.

My problem is

"You are not an Instructor on this site. "
Looks as the same as yours byt I still can't see the group and assign users and give permissions. Any suggestions?
/a
Jun 5, 2009 at 2:10 PM

this was a problem for me too because i was logged in as local admin account and it didn't have rights, so i gave my local admin rights to everything, not just the teacher account in the getting started sample

Jun 5, 2009 at 2:33 PM

Hi, I have added full controll but without positive effect, also to another user and tried

However I'm surfing from outside to the MOSS2007 vhd machine -is that an issue, should I logg in from the server directly?

/a

Jun 5, 2009 at 2:35 PM

nope, didn't work either

Jun 5, 2009 at 2:36 PM

you just need to make sure you add the right SLK Permissions to the user you are logged in with, they are inside of SharePoint, and you have to explicitly grant them, Full Control won't work like that.

Jun 5, 2009 at 2:38 PM

k, but how would I do that, where is this granting page?

Jun 5, 2009 at 2:42 PM

Go to site settings, advanced permissions, then select the user you are needing to edit (if you don't see it add it)

actions > edit permissions

on this screen you should be able to select the proper permissions to see the SLK content

Jun 5, 2009 at 2:54 PM

Hi, found it but when I set SLK Instructor to the local admin and surf to the Plan and Assign page I get an "Unexpected error"

/a

Jun 5, 2009 at 3:30 PM

I'm not sure how much more I can help, since I am new to SharePoint and SLK.

Make sure that you really are on the right site in SharePoint.

Make sure that the SLK database is created.

 

Maybe just try to start over from scratch, sometimes that helps me!

Jun 7, 2009 at 12:14 PM

Hi, natebell,

Sorry I had to go, Yepp I'm restarting from scratch to find out what could have gone wrong.

So far you have been great help, and since I'm new aswell to Sharepoint and SLK you can join the club ;-}

I'm trying to create a traing portal site inside our new Sharepoint intranet. I want to use a simple tool to create the training with, and LCDS seamed like a good tool to use hence my focus on SLK

Same thing for You? Maybe we can hook up our projects?

Jun 8, 2009 at 8:08 AM
Edited Jun 8, 2009 at 11:29 AM

Hi.

I've got it working. Edit web.config and added/set the sessionstate = "true" like this enableSessionState="true"
<pages enableSessionState="true" enableViewState="true" enableViewStateMac="true" validateRequest="false" pageParserFilterType="Microsoft.SharePoint.ApplicationRuntime.SPPageParserFilter, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" asyncTimeout="7">

If it is vital I don't know but I've also added the WebGUID like this <add key="WebSiteGUID" value="a9e3b1bd-0e34-40b7-b9a6-f9850735c3ba" />

Maked sure that the line exists <SafeControl Assembly="Microsoft.SharePointLearningKit, Version=1.3.1.0, Culture=neutral, PublicKeyToken=24e5ae139825747e" Namespace="Microsoft.SharePointLearningKit.WebParts" TypeName="*" Safe="True" />

On errors check/set Login Mappings for NT AUTHORITY\NETWORK SERVICE on SharePiontLearningKit database as db_Owner and Public

Hope this helps

I've got it working

Jun 10, 2009 at 4:19 PM

well I seem to have broken my Course Manager pages.  I am getting the "You are not an Instructor on this site" now

I set my permissions back to SLK Instructor and SLK Learner, but now neither of my accounts administrator or ellenadams will work to access the CM stuff

I'll let you know how i fixed it