Microsoft.SharePointLearningKit

Topics: User Forum
Jun 9, 2009 at 11:37 AM

Hi Guys !

I need some help with the following error message I am geting after I instaled Version 1.3.1 I . I am not sure wher to go and fix this some help would be apresiated

'Microsoft.SharePointLearningKit, Version=1.3.0.2, Culture=neutral, PublicKeyToken=24e5ae139825747e' or one of its dependencies. The system cannot find the file specified.

thanks

Jun 10, 2009 at 2:31 PM

Did you install fresh or did you upgrade from a previous version? Looks like its still looking for the older version of one of the files. See the file Application SLKUpdateTo131.zip under the downloads section for the utilities on upgrading all the references to the latest version.

-Todd

Coordinator
Jun 10, 2009 at 8:54 PM

What are you doing when you get the error?

Richard

SLK Co-ordinator

http://blog.salamandersoft.co.uk

Jun 11, 2009 at 7:20 AM

I am getting this error whenever I try to open a site that had the SLK WebPart. As you can see in this screen short

Coordinator
Jun 11, 2009 at 10:02 AM

There's an incompatibility between 1.3.1 (and later) and any previous versions of SLK. This means that you will need to delete the existing webpart from any pages where it is and add the new one. If there's a small number of pages with it on then you can do it manually by adding ?content=1 to the end of the url e.g. if the page is http://moss/sites/mySchool/mySite then http://moss/sites/mySchool/mySite?contents=1 will allow you to delete the web part even if the page has a fatal error on it.

If you've got a lot of class sites with it on there is a basic tool to automate it at the link with Todd provided above.

I know this is a pain, and the incompatibilities between versions have been a right pain. Future versions will not have this problem.


Richard

Jun 11, 2009 at 1:25 PM

Thanks for your reply,

I have delete the web part but no joy

Any more suggestions?

PS. Thanks for all your support Richard

Coordinator
Jun 13, 2009 at 7:38 PM

Try deleting the web part from the web part gallery and then re-adding it.

Jun 16, 2009 at 11:58 AM

Hi Richard,

Thanks for your suggestion but unfortunately no luck with it

I have got the same error.

If you manage to find the cause I would appreciate if you can let me know how to fix this as at the moment I don’t know what else to try.

Regards

Naeem

From: richardwillis [mailto:notifications@codeplex.com]
Sent: 13 June 2009 19:38
To: Naeem Malik
Subject: Re: Microsoft.SharePointLearningKit [SLK:58894]

From: richardwillis

Try deleting the web part from the web part gallery and then re-adding it.

Read the full discussion online.

To add a post to this discussion, reply to this email (SLK@discussions.codeplex.com)

To start a new discussion for this project, email SLK@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Jun 19, 2009 at 9:12 AM

Sorry for the slight digression, but i need dire help.

I just installed Sharepoint Learning Kit on an already existing MOSS architecture(One Application server and one database server).

I followed every step in the installation manual and my SLK webpart displays with the error message at the right column:

''An error occurred. More information may be available in the server event log.''

 

On checking my server event log, i copied out the following error

SharePoint Learning Kit Error
System.Web.HttpException: Session state can only be used when enableSessionState is set to true, either in a configuration file or in the Page directive. Please also make sure that System.Web.SessionStateModule or a custom session state module is included in the <configuration>\<system.web>\<httpModules> section in the application configuration.

at System.Web.UI.Page.get_Session()
at Microsoft.SharePointLearningKit.ApplicationPages.AlwpQueryResults.get_ObserverRoleLearnerKey()
at Microsoft.SharePointLearningKit.ApplicationPages.AlwpQueryResults.get_SlkStore()
at Microsoft.SharePointLearningKit.ApplicationPages.AlwpQueryResults.Page_Load(Object sender, EventArgs e)

 

Please any help will be greatly appreciated.

 

Regards,

Basil