Sharepoint Learning Kit 1.3.1 error

Topics: Developer Forum
Jun 19, 2009 at 9:10 AM

Help!!!

I just installed Sharepoint Learning Kit on an already existing MOSS architecture(One Application server and one database server).

I followed every step in the installation manual and my SLK webpart displays with the error message at the right column:

''An error occurred. More information may be available in the server event log.''

 

On checking my server event log, i copied out the following error

SharePoint Learning Kit Error
System.Web.HttpException: Session state can only be used when enableSessionState is set to true, either in a configuration file or in the Page directive. Please also make sure that System.Web.SessionStateModule or a custom session state module is included in the <configuration>\<system.web>\<httpModules> section in the application configuration.

at System.Web.UI.Page.get_Session()
at Microsoft.SharePointLearningKit.ApplicationPages.AlwpQueryResults.get_ObserverRoleLearnerKey()
at Microsoft.SharePointLearningKit.ApplicationPages.AlwpQueryResults.get_SlkStore()
at Microsoft.SharePointLearningKit.ApplicationPages.AlwpQueryResults.Page_Load(Object sender, EventArgs e)

I have googled for help to no avail.

Please any help will be greatly appreciated.

flashdazzler

Jun 19, 2009 at 5:14 PM

Hi,

I just installed SLK 1.3.1 on WSS 3.0 on server 2003 EE SP2 today. I went by the instructions for the setup and I am also having the same error on assignments webpart.

I just noticed the following, perhaps corrective action in the readme_131.txt file in the SLK zip. I am yet to give it a try but you can go ahead and advise if that worked for you.

 

This upgrade of SLK uses Sessions. Whether installing afresh or upgrading, sessions have to be enabled for your web application as follows,
 
Locate the root of your web application node and make the following changes to the web.config present in that node,
i. Search and uncomment the following node in web.config
<add name="Session" type="System.Web.SessionState.SessionStateModule"/>
ii. Set enableSessionState attribute of the <pages> element to true

Cheers!

darkoaddison

Jun 22, 2009 at 5:03 PM

Thanks darkoaddison,

It worked like a charm.

After making the two changes on the web.config file and refreshing my 'Learning Center' site, the issue was resolved.

You are officially my hero for 2009 :)

 

Regards,

'dazzler

Jul 22, 2009 at 6:04 PM

I did the aforementioned instructions and everything worked fine. When I configured alternate access mappings, the same error returned. Only this time, the session state is still set to "true." Any ideas?

 

Regards,

Robert

Jul 23, 2009 at 12:22 PM

Hello Rob.

If I am to assume that nothing else has changed besides the alternate access mappings config. then that is the most likely cause. Kindly throubleshoot your access mappings on the webapp making sure everything is well configured. Pay particular attention to the zones for the url mappings. Are the configs for the same zone?

If you are sure everything is correct, you could repeat this in a test environment, configure all alt. access mapping and test them to determine if they work well and then install and cofigure slk.

Perhaps if there was more information about your access mapping configs, I could reproduce your problem or see a pointer to the solution.

Hope this helps,

darkoaddison.

Jul 25, 2009 at 5:41 AM

I believe sometimes when you add an alternate access mapping it also creates a new web site in IIS with a new web.config file. Check that the web.config file for the URL you are using has session state enabled.

Jul 25, 2009 at 8:47 AM
I cant help but agree with jtoddwalker. That is what I meant by alt access mapping being for the same zone or not.

On Sat, Jul 25, 2009 at 4:41 AM, jtoddwalker <notifications@codeplex.com> wrote:

From: jtoddwalker

I believe sometimes when you add an alternate access mapping it also creates a new web site in IIS with a new web.config file. Check that the web.config file for the URL you are using has session state enabled.

Read the full discussion online.

To add a post to this discussion, reply to this email (SLK@discussions.codeplex.com)

To start a new discussion for this project, email SLK@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com