Problem on Assignment web part

Topics: Developer Forum, User Forum
Jul 9, 2009 at 7:41 PM

Hi ,

After i installed the latest version of SLK, and i configure it correctly, after i added the assignment webpart to my page, i got an error on the right pane of the assignment webpart.

 

The message is : An error occured. More information may be available in the server event log.

I checked the error log, and the error is:

"

SharePoint Learning Kit Error

System.Web.HttpException: Session state can only be used when enableSessionState is set to true, either in a configuration file or in the Page directive. Please also make sure that System.Web.SessionStateModule or a custom session state module is included in the <configuration>\<system.web>\<httpModules> section in the application configuration.
   at System.Web.UI.Page.get_Session()
   at Microsoft.SharePointLearningKit.ApplicationPages.AlwpQuerySummary.get_SlkStore()
   at Microsoft.SharePointLearningKit.ApplicationPages.AlwpQuerySummary.Page_Load(Object sender, EventArgs e)

"

 

How can i fix this ?

Jul 9, 2009 at 7:57 PM

Also, i have un commented this attribute on the site web.config file based on the error message shown above:

<httpModules>
      <clear />
      <add name="SPRequest" type="Microsoft.SharePoint.ApplicationRuntime.SPRequestModule, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
      <add name="OutputCache" type="System.Web.Caching.OutputCacheModule" />
      <add name="FormsAuthentication" type="System.Web.Security.FormsAuthenticationModule" />
      <add name="UrlAuthorization" type="System.Web.Security.UrlAuthorizationModule" />
      <add name="WindowsAuthentication" type="System.Web.Security.WindowsAuthenticationModule" />
      <add name="RoleManager" type="System.Web.Security.RoleManagerModule" />
      

        <!-- This was commented and i enable it-->
       <add name="Session" type="System.Web.SessionState.SessionStateModule"/> 
  
      <add name="PublishingHttpModule" type="Microsoft.SharePoint.Publishing.PublishingHttpModule, Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
      <add name="Session" type="System.Web.SessionState.SessionStateModule" />
    </httpModules>

Jul 9, 2009 at 8:05 PM

The solution is just update the web.config with the following:

enableSessionState="true"

and no need to uncomment the System.Web.SessionState.SessionStateModule as mentioned earlier.

 

Hope this helps.