Add webpart via gallery

Topics: Developer Forum, Project Management Forum, User Forum
Sep 17, 2009 at 12:21 PM

Have installed Sharepoint learning kit, all went through fine without any errors.

Following the instructions to the point where it says

 To add the SLK Assignment List Web Part to the Web Part Gallery:<font size="2">

1. Navigate to your SharePoint site

2. On the Site Actions menu, click Site Settings

3. Under Galleries, click Web parts

</font>

4. Click New

5. Check „Microsoft.SharePointLearningKit.WebParts.AssignmentListWebPart‟, and then click Populate Gallery

 

But the Microsoft.SharePointLearningKit.WebParts.AssignmentListWebPart isint not there for me to check?

How do i get it there?

As I said eailer followed the intructions and everything has gone through fine with no errors

<font face="Verdana,Verdana" size="2"><font face="Verdana,Verdana" size="2">

 

 

</font></font><font face="Verdana,Verdana" size="2">

 

</font>

 

 

Oct 15, 2009 at 1:56 PM

I had the same problem and i found what was the problem with my installation. I created a application and site collection after the installation of SLK which created a new web.config which didnt had the safecontrol tag of this feature. So add the following line inside the web.config of the new application and you will have it.

<SafeControl Assembly="Microsoft.SharePointLearningKit, Version=1.3.1.0, Culture=neutral, PublicKeyToken=24e5ae139825747e" Namespace="Microsoft.SharePointLearningKit.WebParts" TypeName="*" Safe="True" />

hope this solves your problem also