Installed, activated, configured... but it isn't.

Topics: User Forum
Dec 7, 2009 at 4:32 PM
Edited Dec 8, 2009 at 12:16 PM

The symptom is the typical 'you haven't configuredSLK for the site you're using' but I have.

Adding the My Assignments web part to a page on the site (and I've tried a few including the homepage) just results in the usual 'This site is not configured to use SharePoint Learning Kit blah blah etc' message.

1) The solution is deployed.

2) It's activated on the correct site.

3) Documents on the site have the E-Learning Actions item.

4) The correct site collection has been configured. The skladm tool confirms this.

4) The database has been created.

However, the permissions SLK Learner etc, do not appear in 'Give users permission directly' of the Add users form.

Any ideas?

TIA.

Coordinator
Dec 8, 2009 at 10:10 AM

It sounds like you forgot to click the create permissions check box when configuring SLK on the site collection. Try reconfiguring it via Central Admin making sure that that check box is ticked, but the create database one is unchecked.


Richard

SLK Co-ordinator

http://blog.salamandersoft.co.uk

Dec 8, 2009 at 12:18 PM
Edited Dec 8, 2009 at 3:04 PM

Damn, I knew I'd leave something out of the first post and get the obvious answer ;)

One of the lines returned by slkadm run aginst the correct site:

Permissions need to be created: False

So, nope, tried that twice already.

Try again :(

Dec 14, 2009 at 4:08 PM

Bump!

Dec 18, 2009 at 11:46 PM

I'm having the same issue. We've installed in our test environment where everything is on one box.

Dec 31, 2009 at 7:26 PM

Bump!

Jan 5, 2010 at 6:44 PM

Ok - I figured out my problem. Being that I'm a total newb, I didn't configure the correct site collection. I figured if I left it at the default, it'd configure for all sites on the server.

The other thing I ran in to was changing the following setting in web.config from false to true...

<pages enablesessionstate="false"

After this, everything has been dandy.