How can you use Class Server's LRE with SLK

Topics: Developer Forum, Project Management Forum, User Forum
Mar 9, 2007 at 11:25 PM
Hello, i'm trying find out the way to make Class Server's LRE work with SLK. I wonder if i have to be connected to the old server(CS) or if i can connect to the new one(SLK), in order to develope new learning resources. I don't know if there's another way to do it. I really hope someone can help me. Thanks.
Mar 13, 2007 at 6:57 AM
As installed with Class Server, the LRE requires a server connection to function, however you can get around this by downloading and installing the Class Server SDK (from http://classserver.msn.com/SDK/Install). This installs a file called LearningResourceEditor.hta that "wraps" the Teacher Client so that LRE can be used without a server connection.
Mar 13, 2007 at 7:27 PM
Thank you very much. This solves my problem.
Mar 14, 2007 at 10:28 AM
This partly solves a problem for me also.

Has anyone else experienced the following?

When creating a quiz or assignment, the edit question and delete question icons at the top right corner of each question are missing. They are each displayed as a red X.
Any ideas why the editor can't display the icons?
Mar 14, 2007 at 5:18 PM
Hi group

Sorry if this is listed in the readme or instructions for the new SLK (havent got around to reading all the material yet) but i thought the SLK replaces the need for classroom server? If not what other functionality does classroom server provide us with?
May 17, 2007 at 6:39 PM
Ok, so I am a little lost.
I have downloaded the ClassServer SDK and installed it, but I don't see this LearningResourceEditor.hta and beyond that, once I find the file I don't know what to do.
What steps need to be done to get the techer client working without the need for the server connection?
Thanks for the help in advance.
May 17, 2007 at 7:10 PM
Ok, let me clerify.
I have installed the SDK, after installing the teacher client and in the "c:\program files\microsoft class server\learningresource" folder there is no LearningResourceEditor.hta (as per this article: http://www.learninggateway.net/SLK/SLK%20Specifications/Learning%20Resource%20Development%20Guide.doc)
I have tried everything, and http://classserver.msn.com/SDK/Install/ is no longer up so the version of the SDK I was able to find is 4.0.49.
Does anyone have any idea or could anyone send the files I need my way? Thanks.
Nov 7, 2007 at 7:08 PM
I installed the SDK and I can succesfully start the HTA file. But when I create a new package I receive this error in the client:

The computer cannot load this page due to the following error: Object doesn't support this property or method (0xa01b6)

Than I can click on OK and I can save the package. But the problem is that I never could create any questions.

I use Vista and I am running the program as administrator but the same error occured.

Thanks
Coordinator
Nov 7, 2007 at 8:06 PM
I'm not an expert on Class Server LRE, but I've heard that there are compatibility issues between LRE, Vista, and IE7. Unfortunately, development and support of Class Server LRE has halted at Microsoft so there are no plans to fix these compatibility issues. In the mean time, we are actively working on a new educational content tool called Grava which we hope will help fill this gap. I'm actively working on integrating Grava with SLK in particular and LMSes in general right now.


remcoploeg wrote:
I installed the SDK and I can succesfully start the HTA file. But when I create a new package I receive this error in the client:

The computer cannot load this page due to the following error: Object doesn't support this property or method (0xa01b6)

Than I can click on OK and I can save the package. But the problem is that I never could create any questions.

I use Vista and I am running the program as administrator but the same error occured.

Thanks