Re-deployment Issue

Topics: Developer Forum
Mar 21, 2007 at 5:15 PM
I'm unable to retract the SLK solution file. After launching the RetractSolution.cmd the Enumsolutions.cmd displays Retraction Pending and is just sits there for hours. The Timer Job Definition to retract the solution is scheduled for one-time, all of the Timer job status are Succeeded at 100%, but the solution doesn't retract, it just sits there.

<Solutions Count="2">
<Solution Name="applicationtemplatecore.wsp">
<Id>0273f170-f34b-4f05-9973-494e875dee24</Id>
<File>applicationtemplatecore.wsp</File>
<Deployed>TRUE</Deployed>
<WebApplicationSpecific>FALSE</WebApplicationSpecific>
<ContainsGlobalAssembly>TRUE</ContainsGlobalAssembly>
<ContainsCodeAccessSecurityPolicy>FALSE</ContainsCodeAccessSecurityPolicy>
</Solution>
<Solution Name="sharepointlearningkit.wsp">
<Id>00057001-c978-11da-ba52-00042350e42e</Id>
<File>SharePointLearningKit.wsp</File>
<Deployed>TRUE</Deployed>
<WebApplicationSpecific>TRUE</WebApplicationSpecific>
<ContainsGlobalAssembly>TRUE</ContainsGlobalAssembly>
<ContainsCodeAccessSecurityPolicy>FALSE</ContainsCodeAccessSecurityPolicy>
<Deployment WebApplication="http://mossrtm:8080/" />
<Deployment WebApplication="http://mossrtm:81/" />
<Deployment WebApplication="http://mossrtm/" />
<SolutionDeploymentJob id="516a347e-235c-4476-be80-259c7b9c19b3">
<Title>Windows SharePoint Services Solution Retraction for "sharepointlearningkit.wsp"</Title>
<Type>Retraction</Type>
<State>Pending</State>
</SolutionDeploymentJob>
</Solution>
</Solutions>

Is there any other way to retract / remove the SLK solution manually so I can re-deploy it?
Mar 23, 2007 at 1:58 PM

Killing the timer job and retrying retracting might work
Mar 23, 2007 at 4:35 PM

VandanaPonnuru wrote:

Killing the timer job and retrying retracting might work

I was able to delete the solution with the -override parameter and then run the reinstallSolution.cmd and fully recovered from this tragedy.
Mar 29, 2007 at 9:41 AM
Edited Mar 29, 2007 at 9:44 AM


I was able to delete the solution with the -override parameter and then run the reinstallSolution.cmd and fully recovered from this tragedy.



thanks!!!
I had the same problem and this helped me alot!!