A review problem in SharePoint Services 2007?

Topics: Developer Forum, Project Management Forum, User Forum
Mar 28, 2007 at 3:21 PM
Edited Mar 28, 2007 at 3:33 PM
Hi, can anybody help me with a problem in SharePoint Services 2007?
I use Articulate Quizmaker for creating tests (SCORM 2004 package). I noticed an important problem with the review function. After a learner has completed and submitted the assignment and i`m about to grade it I click on the learner name to review the test but an error appears:
1. A popup window with this message:
http://img163.imageshack.us/img163/9430/123vt4.gif

2. A second popup window apears with this text:
0:Wed Mar 28 16:06:08 UTC+0300 2007 - AICCComm - Trying to create MSXML2.XMLHTTP in VBScript
1:Wed Mar 28 16:06:08 UTC+0300 2007 - AICCComm - intReCheckLoadedInterval=250
2:Wed Mar 28 16:06:08 UTC+0300 2007 - AICCComm - intReCheckAttemptsBeforeTimeout=240
3:Wed Mar 28 16:06:08 UTC+0300 2007 - AICCComm - IFrameLoaded
4:Wed Mar 28 16:06:08 UTC+0300 2007 - AICCComm - In GetAICCURL
5:Wed Mar 28 16:06:08 UTC+0300 2007 - In GetQueryStringValue strElement=AICC_URL, strQueryString=
6:Wed Mar 28 16:06:08 UTC+0300 2007 - Looking at element-
7:Wed Mar 28 16:06:08 UTC+0300 2007 - Looking at element-
8:Wed Mar 28 16:06:08 UTC+0300 2007 - No Match Found, returning empty string
9:Wed Mar 28 16:06:08 UTC+0300 2007 - AICCComm - Querystring value =
10:Wed Mar 28 16:06:08 UTC+0300 2007 - AICCComm - GetAICCURL returning:
11:Wed Mar 28 16:06:08 UTC+0300 2007 - AICCComm - LMS and Content Domains don't match, falling back to write-only mode using form submit. strLmsDomain=, strContentDomain=dambo
12:Wed Mar 28 16:06:08 UTC+0300 2007 - AICCComm - blnCanUseXMLHTTP=false
13:Wed Mar 28 16:06:08 UTC+0300 2007 - AICCComm - blnCanUseIFrame=false
14:Wed Mar 28 16:06:08 UTC+0300 2007 - In Start - Version: 3.1.3 Last Modified=03/28/2007 16:06:08
15:Wed Mar 28 16:06:08 UTC+0300 2007 - Browser Info (Microsoft Internet Explorer 4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 1.1.4322))
16:Wed Mar 28 16:06:08 UTC+0300 2007 - URL: http://dambo/armands/layouts/SharePointLearningKit/Frameset/Content.aspx/3/801/12083/indexlms.html
17:Wed Mar 28 16:06:08 UTC+0300 2007 - In ClearErrorInfo
18:Wed Mar 28 16:06:08 UTC+0300 2007 - In GetQueryStringValue strElement=StandAlone, strQueryString=
19:Wed Mar 28 16:06:08 UTC+0300 2007 - Looking at element-
20:Wed Mar 28 16:06:08 UTC+0300 2007 - Looking at element-
21:Wed Mar 28 16:06:08 UTC+0300 2007 - No Match Found, returning empty string
22:Wed Mar 28 16:06:08 UTC+0300 2007 - In GetQueryStringValue strElement=ShowDebug, strQueryString=
23:Wed Mar 28 16:06:08 UTC+0300 2007 - Looking at element-
24:Wed Mar 28 16:06:08 UTC+0300 2007 - Looking at element-
25:Wed Mar 28 16:06:08 UTC+0300 2007 - No Match Found, returning empty string
26:Wed Mar 28 16:06:08 UTC+0300 2007 - strStandAlone= strShowInteractiveDebug=
27:Wed Mar 28 16:06:08 UTC+0300 2007 - In ConvertStringToBoolean
28:Wed Mar 28 16:06:08 UTC+0300 2007 - In EqualsIgnoreCase str1=, str2=true
29:Wed Mar 28 16:06:08 UTC+0300 2007 - Returning false
30:Wed Mar 28 16:06:08 UTC+0300 2007 - In EqualsIgnoreCase str1=, str2=t
31:Wed Mar 28 16:06:08 UTC+0300 2007 - Returning false
32:Wed Mar 28 16:06:08 UTC+0300 2007 - Returning false
33:Wed Mar 28 16:06:08 UTC+0300 2007 - Standard From Configuration File - SCORM2004
34:Wed Mar 28 16:06:08 UTC+0300 2007 - Using Standard From Configuration File - SCORM2004
35:Wed Mar 28 16:06:08 UTC+0300 2007 - In LMSStandardAPI strStandard=SCORM2004
36:Wed Mar 28 16:06:08 UTC+0300 2007 - In ConvertStringToBoolean
37:Wed Mar 28 16:06:08 UTC+0300 2007 - In EqualsIgnoreCase str1=, str2=true
38:Wed Mar 28 16:06:08 UTC+0300 2007 - Returning false
39:Wed Mar 28 16:06:08 UTC+0300 2007 - In EqualsIgnoreCase str1=, str2=t
40:Wed Mar 28 16:06:08 UTC+0300 2007 - Returning false
41:Wed Mar 28 16:06:08 UTC+0300 2007 - Returning false
42:Wed Mar 28 16:06:08 UTC+0300 2007 - Calling Standard Initialize
43:Wed Mar 28 16:06:08 UTC+0300 2007 - In SCORM2004_Initialize
44:Wed Mar 28 16:06:08 UTC+0300 2007 - In SCORM2004_ClearErrorInfo
45:Wed Mar 28 16:06:08 UTC+0300 2007 - Grabbing API
46:Wed Mar 28 16:06:08 UTC+0300 2007 - In SCORM2004_GrabAPI
47:Wed Mar 28 16:06:08 UTC+0300 2007 - Searching with Rustici Software algorithm
48:Wed Mar 28 16:06:08 UTC+0300 2007 - Grab API, returning, found API = false
49:Wed Mar 28 16:06:08 UTC+0300 2007 - Unable to acquire SCORM API:
50:Wed Mar 28 16:06:08 UTC+0300 2007 - SCORM2004_objAPI=undefined
51:Wed Mar 28 16:06:08 UTC+0300 2007 - In InitializeExecuted, blnSuccess=false, strErrorMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.
52:Wed Mar 28 16:06:08 UTC+0300 2007 - ERROR - LMS Initialize Failed
53:Wed Mar 28 16:06:08 UTC+0300 2007 - In DisplayError, strMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.


What can i do to fix this and make the review function properly?
Mar 29, 2007 at 10:07 AM
Hi,

The old browser version (IE 4.0, that is listed in the info) could be the reason. Articulate Quizmaker seems to require atleast 5.0 or later. Their website might have more info on the right browser version to use.

Mar 29, 2007 at 3:12 PM
Thank`s for the tip, but i am using IE7, so why does the system show IE4? I got the idea to do some tests on IE6 and there was a progress - i got only the first error message (http://img163.imageshack.us/img163/9430/123vt4.gif) and after pressing OK everything worked, but still why do i get the weird error?