Sharepoint Learning Kit External Access

Topics: Developer Forum, Project Management Forum, User Forum
Apr 25, 2007 at 11:14 AM
I have setup SharePoint to work externally, which is all functioning correctly. I have setup the SharePoint Learning kit and when I click on My Assignments externally it tries to connect to the internal address, it doesn’t resolve it to the external URL

Any help would be appreciated
Apr 30, 2007 at 10:41 AM
Same problem here, does it just not work externally?
Apr 30, 2007 at 12:30 PM

zag wrote:
Same problem here, does it just not work externally?


Yeah, no problem internally just externally.
Apr 30, 2007 at 8:20 PM

Though I have not got an opportunity to try it out, Issue 7835 corresponding to this problem, has a proposed solution.
May 9, 2007 at 8:51 AM
it says thread 7835 is there - please post the full URL - thanks

Alex
May 9, 2007 at 2:19 PM
You have to change the default web address in Central Admin.

Go to Central Admin - Operations - Alternative Access Mapping and change the default webaddress for your application.

It seems that SLK only works with the default access address.
May 23, 2007 at 5:25 PM
Edited May 23, 2007 at 5:25 PM
Hi, I recently enabled Alternative Access Mapping to allow a sharepoint site to be accessed externally after experiencing the problem of the site referring to the internal address. It is now only the assignments in the My assignments web part that have the problem. I can't access Alternative Access Mapping as I get an "Unknown Error" message when I try to do so. Yesterday I had to use an stsadm command to set up the alternative access mapping. I found the command at the following link: http://www.toddklindt.com/blog/Lists/Posts/Post.aspx?ID=39

I could access the Alternate Access Mapping after I used the command but for some reason I can now longer access the links within the Operations section of the WSS Admin.

Does anyone know of such a command to change the default web address as mentioned above by apearce?

Any info would be greatly appreciated.
May 23, 2007 at 8:35 PM
As an update to my previous post, this worked for me...

From the command prompt I had to change directory to "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN"

Then I ran the following command: "stsadm -o addzoneurl -url http://defaultwebaddress -urlzone default -zonemappedurl http://www.externaladdress.com"
I'm not sure if it's the correct command to use but now I can access the assignments in SLK through the external web address.

I had to use the command because after converting a physical machine to a virtual machine I can no longer access the links within the Operations section of the WSS Admin.

Hope this helps some people.