Frequently Asked Questions About SLK

Where do I get support for SharePoint Learning Kit?

SharePoint Learning Kit is a community source project. As such, product support is provided via this community Codeplex site. While Microsoft engineers are actively involved in the community development and leadership, Microsoft product support does not provide support for SharePoint Learning Kit. Please post any issues or questions to the SLK Codeplex forums.

How do you get checkin rights for SLK? Who decides what goes into SLK and what stays out?
See Community Roles

How do I check in a bug fix or new feature for SLK?
See Checking In

*How do I test someone else's patch for a bugfix or a new feature?
See Test a Patch

How do I help localize SLK?
See HowToCheckInTranslationXMLFiles

Installation, Configuration and Deployment

I'm having trouble deploying SLK

Several of you have had trouble deploying SLK under certain configuraitons, most notably on a domain controller. If you are having this problem, try editing the installation/deployment CMD files to replace 'localhost' with the fully-qualified domain name of your server or server farm. We have not tested this yet, but on one of the discussion threads, a member of our community suggested that it might work.

When I run EnumSolutions.cmd, it tells me that deployment failed, or deployment has been pending for a long time

If deployment fails, you can often determine the cause by reviewing the latest .log file in the WSS LOGS directory (typically "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\LOGS"). Regardless of the reason, you must cancel the deployment job before you can try again. To cancel a deployment job, go to SharePoint Central Administration, Operations, Timer Job Definitions, click on the deployment job, and click "Delete".

I've installed and configured SLK, but "E-Learning Actions" is not showing up on my document library menu

In order to assign content from a document library, the site that the document library is on must have the SharePoint Learning Kit feature activated. If you don't see the 'E-Learning Actions' item, it's usually because you haven't activated the feature, or you activated it, but the document library you're using isn't on the site that you activated it on. To be sure it's activated on the right site:
  1. Be sure you are signed in to SharePoint with permissions that allow you to change site settings
  2. Navigate to the document library that you want to assign from
  3. On the Site Actions menu, click Site Settings
  4. Under Site Administration, click Site features
  5. On the SharePoint Learning Kit row in the list of site features, click Activate

I've installed and configured SLK, but the Assignment List Web Part is not showing up in my Web Part Gallery

In order for the ALWP to show up in the Web Part Gallery on a site collection, it has to be added to the gallery on that site collection. The procedure for this is documented in Section 2.2.3 of the GettingStarted document (at the bottom of Page 6):
  1. Navigate to the top-level site in your site collection
  2. On the Site Actions menu, click Site Settings
  3. Under Galleries, click Web parts
  4. Click New
  5. Check Microsoft.SharePointLearningKit.WebParts.AssignmentListWebPart, and then click Populate Gallery

Last edited Nov 30, 2007 at 5:03 PM by JayBeavers, version 14

Comments

kbans Jun 12 at 7:36 PM 
Hey everyone,

I am currently working in a company to develop E-Learning materials to help train new hires. I am using Articulate Storyline to make quiz content and uploading the content to SharePoint with the SharePoint Learning Kit, SLK. Here is some information that you can follow and hopefully help me with configuring SLK to grade my Articulate quizzes.

First, I want to outline the progress I have currently made so that anybody can see if the problems I have are due to things I already did:

- Used Articulate Storyline to make Presentations with Quiz questions in them that are graded and reviewed at the end of the Presentation
- Published the Storylines to LMS in SCORM 2004 format and saved to my computer
- Took each published Storyline and made .zip files
- Uploaded .zip files to SharePoint 2010 with SLK (SharePoint Learning Kit). Can assign Learners with .zip files as long as they download them, extract them, and find the ‘story.swf’ flash file that runs the Presentation so they can go through the Storylines, answer quiz questions, and receive a quiz grade at the end of them

The issue is that after downloading each .zip file, running the Presentation, and finishing the Quiz questions at the end of them, the information cannot be stored or saved and re-submitted to SLK which should then automatically read the Quiz progress and log in a grade as well as log in completion of the assignment due to passing grades.

The questions at hand are:

- How to save or store graded information from the Presentations so that they can be submitted to SLK?
- How to make sure SLK takes in the graded information submitted from the Presentations automatically, store it, and reveal them?
- How to make sure SLK determines assignment completion and passing assignments grade-wise?

I watched videos of how SLK grades the quiz content and I think that will work, but I think my main issue is saving that quiz content and getting to submit to SLK for grading.

I have uploaded an example of the content I want to post on my company's SharePoint page.

Thank you for your time and consideration and any help would be greatly appreciated.

Sincerely,
Kevin Bansleben

amitpatil85 Nov 14, 2013 at 4:30 AM 
Hi,

We want to integrate SLK in sharepoint 2013 so I have downloaded the package SLK 1.7 version. In package there sharepoint 2013 folder is there but in the installation instruction they haven't mentioned the steps for SharePoint 2013.

If anybody knows the steps in cloud and in on premises then can you please send it to me??

MV16 Jan 31, 2013 at 3:04 PM 
If a teacher accidentally deletes an assignment, and therefore all the associated documents attached to it that have been returned to learners, what's the best way of getting it all back?

zwelding Oct 30, 2012 at 5:34 PM 
Is it possible for this solution to be written or used as sandboxed solution? I have a client that uses SharePoint online that would love to use this product.

vinodj Aug 2, 2012 at 4:59 PM 
Will Sharepoint Learning Kit work on Windows Server Standard 2008?

mohamedakb Jul 4, 2012 at 4:39 AM 
Hi,
How to remove items (assignments) from AssignmentListWebPart?? When I remove from Material document library, the assignment still there in the AssignmentListWebPart.

kimtuan8286 Mar 21, 2012 at 3:57 AM 
Hi, I has just Installed SLK in my Potal. So, How SLK interactive with database? For Example, by entities framework, by directly to table, ... Or something case. Can any body help me to solve this problem. Thanks you so much.

Bijal_Bhatt Mar 9, 2012 at 10:18 AM 
Hi,
We have a requirement of creating reports related to the score of each learner. Can i get details exactly where the scores are stored?

louisefairman Jan 3, 2012 at 7:21 PM 
Hi all,
I am using articulate quizmaker which is SCORM 4 compliant and I have recently installed the LMS part of sharepoint and I am having trouble getting it to work - The specific problem I have is that i am assigning the quiz .html to the learner and when the learner tries to take this assesment it navigates to a page that cant be displayed. I have also seen that you may need to upload the quiz as a .zip file but when I do that and assign the .zip file to the learner they just see 20 files and dont know which one to choose, can anyone help me please? I think this is the same problem as a previous post:

amarendra4ever Sep 8 2009 at 11:59 AM
I am able to successfully deploy SLK 1.3.1 into my sharepoint environment and I am able to assign and host the course from the 'My Assignment' web part also but my only problem is, when I am trying to launch the SCORM file 'Solitaire.zip' I see '404 NOT FOUND'. The URL from my local site is: http://wipro-awvvitwot:33526/Mission10x/Faculty/_layouts/SharePointLearningKit/Frameset/Frameset.aspx?SlkView=Execute&LearnerAssignmentId=100c7f4a-09d5-4fc7-874c-143a28d12fba

thilipan Dec 23, 2011 at 10:15 AM 
Hi,

anybody know how to migrate SLK from SharePoint 2007 to SharePoint 2010?
searching for step by step guide.

Thx
Thilip

bislander Apr 14, 2011 at 4:33 PM 
Your instruction on how to add a web part are inacurrate & misleading.

In order for the ALWP to show up in the Web Part Gallery on a site collection, it has to be added to the gallery on that site collection. The procedure for this is documented in Section 2.2.3 of the GettingStarted document (at the bottom of Page 6):

Navigate to the top-level site in your site collection
On the Site Actions menu, click Site Settings
Under Galleries, click Web parts
Click New - why add new? If the solution was installed correctly, and features are activated that should create a web part in the web part gallery. I am failing at this point, click new suggests that I need to upload a web part, where from? Could you please clarify?
Check Microsoft.SharePointLearningKit.WebParts.AssignmentListWebPart, and then click Populate Gallery

bislander Mar 24, 2011 at 10:21 PM 
Hi,
I am about to install SLK kit on a virtual machine that's running on Windows 8R, 64-bit machine.
The instructions that are listed on this site are for Windows Server 2003.

Which download version should I choose for this installation.
And has anyone actually done that on Windows Server 2008?

very resperctfully,
Basia

brunocastrillon Jun 9, 2010 at 1:38 AM 
Hello, I am studying the possibility of deploying Sharepoint as a tool for E-Learning, however my company has licenses for Sharepoint 2010, I wonder if the SharePoint Learning Kit is compatible with this new version.
This kit work in an environment: Windows 2003 or 2008 / Windows SharePoint Services 2010?

Thanks for your help!

qaaweb Mar 12, 2010 at 4:35 PM 
Hi. We are implementing SharePoint as part of an organisation-wide project, and have also dabbled (unsuccessfully) with some LMS's, so thought we'd give the SLK a try. We have an existing Scorm (1.2) compliant course that we had for our previous LMS, but this does not work with SLK - there is a 'File download' dialogue box. We have got SLK to work with another course, so think we have got it set up OK. Any suggestions on what we could do? Or do some courses simply not work ? Thanks.

slkuser Sep 29, 2009 at 4:04 PM 
Can SLK generate a flat file--particularly of trainings completed per staff member--to export to other databases? If so, how? Thanks! --Wes

rajeshtouti Sep 18, 2009 at 5:01 AM 
From: rajeshtouti
Hi,
I have configured SLK (1.4) on our portal and when i tried to activate the Feature in sharepoint I get error message as " Dependency feature with id 5bf217da-245c-40c0-a65b-0a6482f73c84 for feature 'SharePointLearningKit' (id: 00057002-c978-11da-ba52-00042350e42e) is not installed."
can someone please help ...
i have followed the Guide SLK 1.4

Thanks in Advance

Raj

amarendra4ever Sep 8, 2009 at 10:59 AM 
I am able to successfully deploy SLK 1.3.1 into my sharepoint environment and I am able to assign and host the course from the 'My Assignment' web part also but my only problem is, when I am trying to launch the SCORM file 'Solitaire.zip' I see '404 NOT FOUND'. The URL from my local site is: http://wipro-awvvitwot:33526/Mission10x/Faculty/_layouts/SharePointLearningKit/Frameset/Frameset.aspx?SlkView=Execute&LearnerAssignmentId=100c7f4a-09d5-4fc7-874c-143a28d12fba

alisah Jul 20, 2009 at 4:03 PM 
We have a customer trying to develop a way to test their employees on HIPAA information. They would like for the employees to be able to take a test and have to instantly reanswer any questions that were incorrect. They would have to keep answering these questions until their answers were correct. We also need a way to verify that every employee has taken the test, maybe a report. Does this kit have these features? Thanks for your help!

cymarven Jun 25, 2009 at 1:41 PM 
Hi all. We have recently installed SLK into our sharepoint portal. I have worked out how to create content based assignments with the odd multi choice however I would like to set tasks to be completed in Word/Excel and submitted for assessment through SLK. Is this possible?

jrubinstein Jun 6, 2009 at 5:51 PM 
I have managed to solve this. I found the webpart was available - at the central administration site!

1. I populated the central site with the web part, then exported it to a file on the server.

2. From the site for which I had configured the database I then imported the web part.

3. I copied the reference in the safe control section of the web.config file for the central admin site into the web.config of the learning kit site.

4. I set the sessionstate of the learning kit site to true.

That worked.

nallagh Jun 2, 2009 at 7:21 PM 
I am having the same problem as slkmatrix, jriesen, jrubinstein. Can someone help?

jrubinstein Jun 2, 2009 at 1:27 PM 
I am having the same problem as slkmatrix and jriesen. Given their comments are 4 months apart and nobody has replied I am forced to believe that either the three of us are being stupid or nobody is watching this discussion.

jriesen May 14, 2009 at 2:38 PM 
I am having the exact same issue as slkmatrix. I thought I found what would be some help in this post from http://slk.codeplex.com/Wiki/View.aspx?title=SLK%20FAQ which talks about downloading the webpart from the source code, but that didn't pan out. No webpart in the downloads area indicated. some help would be appreciated.

slkmatrix Feb 3, 2009 at 7:30 PM 
I have configured my demo site to use SLK. I have activated SLK in my site. When I go to add new web part from web part galleries, I do not see Microsoft.SharePointLearningKit.WebParts.AssignmentListWebPart. Please help.
I have 2 web applications. I have already configured SLK to be used on one of the site collection under one of the web applications. It works fine. However, I just cannot see the web part on the other site collection in another web application. Am I making sense?

Bender101 Dec 1, 2008 at 6:19 PM 
HELP!!!

I've successfully (I believe) installed, configured and enabled the SLK on Sharepoint (WSS 3.0) BUT when i Add the AssignmentListWebPart onto my page I get an error stating "An error occurred. More information may be available in the server event log.". I go to my error Logs and this is what it says...

12/01/2008 11:48:16.96 w3wp.exe (0x01A0) 0x0F9C Windows SharePoint Services General 88jb Medium Feature Activation: Activating Feature 'SharePointLearningKit' (ID: '00057002-c978-11da-ba52-00042350e42e') at URL http://trainingportal.

12/01/2008 11:48:16.96 w3wp.exe (0x01A0) 0x0F9C Windows SharePoint Services General 75f8 Medium Feature Activation: Feature 'SharePointLearningKit' (ID: '00057002-c978-11da-ba52-00042350e42e') was activated at URL http://trainingportal.

12/01/2008 11:48:33.60 w3wp.exe (0x01A0) 0x0F9C Windows SharePoint Services General 8e25 Medium Failed to look up string with key "DistributionLists_Alias", keyfile core.

12/01/2008 11:48:33.60 w3wp.exe (0x01A0) 0x0F9C Windows SharePoint Services General 8l3c Medium Localized resource for token 'DistributionLists_Alias' could not be found for file with path: "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\xml\base.xml".


I'm a newb when it comes to Sharepoint and the SLK and getting rather frustrated...Googling this seems to bring up, that i'm not the only one with this problem but there doesn't seem to be any solutions.
thanks in advanced for any help with this!!
Bender

Trandy Jun 30, 2008 at 5:13 AM 
Is it possible to disable some features of SLK? I'm looking at disabling the working flow feature of submitting assignments. I just want a feature that allows tutorials to be presented. Is this the best project to use?

vgango May 22, 2008 at 3:31 AM 
I have successfully installed and managed to run SLK on Sharepoint. Can anybody help me on How to pass answers of Essay type from Learning management content to LMS (SLK on Sharepoint). Can i do the assessment of these answers from SLK?

regards

Vijitha

Kieran Apr 30, 2008 at 2:28 PM 
Hello Martin,
I had a similar problem: installed SLK, deployed successfully, activated feature within site but no ALWP assignment webpart.
To make the webpart appear:
1) download the source code: http://www.codeplex.com/SLK/SourceControl/ListDownloadableCommits.aspx
2) find the Assignments.webpart file in the SLK directory
3) Upload this as a new webpart to the Webpart Gallery for the site you want to use the webpart
4) find the Manifest.xml file in the SLK directory of the source code you downloaded.
5) Extract the <SafeControl Assembly="Microsoft.SharepointLearningKit, Version=1.3.0.2, ... tag from Manifest.xml and add to the correct portion of the web.config file in the virtual directory of the Sharepoint website.. ie C:\inetpub\wwwroot\wss\virtualdirectories\portnumber\web.config (you will see many other SafeControls added so just add it to the end of the list)
6) Do an iisreset at the command prompt for good measure.

That should be it! Hope that helps,
Kieran

llaske Feb 28, 2008 at 3:21 PM 
Hi,

I'm new to SLK and I want to apply the French Language Pack on my SLK 1.3.
Unfortunatly, I can't find where I can download the Language Pack and what should I do to apply it.
The only file that I've get is the "TranslatedXMLs-1036.zip". Could you give me the link to get the french language pack ?
Thanks in advance for your help.

Lionel.

martinrousev Jul 27, 2007 at 6:58 AM 
Hello,

Regarding the last question it the FAQ about the assignment web part I encountered the following problem: I installed SLK, deployed the solution, configured it in the central administration site, activated it in the sharepoint application, but the web part is not there. I go to 'Site Settings -> Web parts ->New' and there is no such web part in the list. I checked the GAC and the .dll file that contains the part is not there. I tried to add it manually but still the web part is not in the list. If any of you knows how to fix this problem please do so.
Thanks in advance
Martin Rousev

cervisia Mar 2, 2007 at 2:22 PM 
Hi,

I had the error / problem that JTimblin described above: "Error: Cannot add the specified assembly to the global assembly cache: Microsoft Learning Components.dll.". Unfortunately the solutions didn't work for me.

What I did to solve the problem was uninstalled the SLK and started from scratch. Also I noticed that my server was using an awful lot of memory and this was also appearing in the event viewer as Office SharePoint Server errors ("System.OutOfMemoryException" / "Not enough storage is available to complete this operartion"). Due to this it was impossible to deploy correctly.
Hope this helps.
Mark van Lunenburg
Wortell bv

JTimblin Dec 10, 2006 at 7:16 PM 
A possible FAQ append for "I'm having trouble deploying SLK"...

If you use stsadm -o deploysolution to attempt to deploy non-strongly signed SLK assemblies to the GAC before setting verification via sn.exe or you forget to add sn.exe to the shell path before running SkipVerification.bat (causing SkipVerification.bat to fail) then deployment will likely fail with a log error like "Error: Cannot add the specified assembly to the global assembly cache: Microsoft Learning Components.dll." When this failure happens, the WSSADMIN.exe process appears to cache the failed results from the subprocess (FUSION.DLL?) that handles strong name verification. This means that even if you retract the solution/remove timer job, GAC assemblies, etc. and go back and run sn -Vr "*,abc4ed181d6d6a94" and try to redeploy, your deployment job may continue to fail.

It appears that one can workaround this issue by restarting the wssadmin.exe process, e.g CMD, net stop "Windows SharePoint Services Administration" && net start "Windows SharePoint Services Administration".

Also, if you are running on a domain controller where wssadmin.exe, owstimer.exe and other SharePoint services are running under an Active Directory domain account, then you can also run sn -Vr specifying the [<userlist>] arg. Example, sn -Vr "*,abc4ed181d6d6a94" "domain\sharepoint_services_account".