This project has moved and is read-only. For the latest updates, please go here.

Database Permissions on Master?

Topics: Project Management Forum, User Forum
Jun 4, 2007 at 6:42 PM
I entered a post on Friday about not being able to post web parts. I thought that the problem might have been with the path that I used in the DeploySolution command file. I had a port on there, but then I was working on a sub-site that was not using the same port. I decided to retractsolution and deletesolution to start over.

Second time through I didn't put a port on the path in the DeploySolution command file. This time I just used the server name (http://learningserver). Now when I try to go in to the SLK through Central Administration, I get the error - CREATE DATABASE permission denied in database 'master'.

Does the SLK really need to create something in the master database?
Jun 5, 2007 at 2:06 AM
Hey Eric,

Not sure I'm following you here. When you deploy your solution, you are pointing it at a specific application via the url path in the DeploySolution command file. This will then install it for all sites in the application.

During the install process, the Geting Started guide should walk you through all the necessary set-up. Sounds like you missed a step perhaps?

Jun 7, 2007 at 9:04 PM
I stuck this on another post that I started, but it really should have gone on this one. Sorry.

On Tuesday I decided to remove SharePoint and start over because I was having so many problems. After that Windows would not boot up again. It would go through the boot sequence, and it would get to where the windows server status bar was scrolling, but then it would cycle and reboot itself. Anyway, I had to spend all day Wednesday rebuilding the server with a fresh install of Windows, SQL Server, the service packs, and SharePoint.

Today I finally got to the point to where I was going to add in the SLK. Everything goes fine until I try to configure the SLK. I am still getting the "CREATE DATABASE permission denied in database master" error.

Has anyone tested this with SQL SP2. that just came out about two weeks ago. Maybe that is causing problems for me.
Jun 7, 2007 at 10:50 PM
Wow, I just did the same thing you did Eric in getting a new dev server going for my group.

Installed Windows Server 2003 64-bit, SQL 2005, All necessary SPs and updates, and then installed SLK.

I get the same error "CREATE DATABASE permission denied in database master" when trying to configure.
Jun 7, 2007 at 11:01 PM
More info...

I have multiple instances of SQL running on my machine.

1. SLKTP (default)
2. SLKTP\SQLEXPRESS (not used)
3. SLKTP\OFFICESEVERS (used by SharePoint)

The configuration would error if I tried to install it to SLKTP (where I wanted it). However, it configured successfully on SLKTP\OFFICESERVERS. I assume that there is some permissions I'm missing here, what are they?
Jun 7, 2007 at 11:09 PM
Well, I guess that I am glad to hear that I am not alone, but at the same time I'm sorry to hear that you are also having the problem. I wouldn't wish this on anyone because it has really been a headache.

Currently I'm on a 32 bit system (x86), so that apparently doesn't have anything to do with it.

Did you install SP2? If so then my guess is that it has something to do with SP2 because I think that it just recently became avaliable.
Jun 7, 2007 at 11:27 PM
I have noticed something else that seems odd. The name of the test server that I am working on is called LearningServer. In SQL I have both a LEARNINGSERVER db engine and a LEARNINGSERVER\OfficeServers db engine. The LEARNINGSERVER\OfficeServers db engine didn't show up until I installed the trial version of SharePoint.

Is this normal? In a sense this causes two 'master' databases to be created (I think), so this might have something to do with the problem.
Jun 8, 2007 at 5:06 PM
Hey Eric,

When you do a basic install of SharePoint, it sees that you have SQL installed and automatically creats it's own instance called YOURSERVER\OfficeServers.

Kinda strange that it dosen't ask you, but I guess that's what simple means. ;-)
Jun 8, 2007 at 5:33 PM
I guess so. On my initial installation I chose the advanced install, and then picked the Stand-alone option to install all components on a single machine. In that situation it seems to do the same thing as the basic installation, but doesn't add the YOURSERVER\OfficeServers as the database engine for SharePoint.
Thanks again!