This project has moved and is read-only. For the latest updates, please go here.

Configure SharePoint Learning Kit

Jun 11, 2008 at 8:41 PM
I've searched through the previous discussion threads for the issue I'm running into but have not located a solution. Have installed the SLK but cannot get the database configuration to run in our test environment - Win2003 & SQL 2005. I saw this sentence from a seperate thread which explains why I haven't been able to get it installed: "The user you are accessing the configuration page as needs access to the instance of SQL that you specify in the “Database server” field of the configuration page. Otherwise, you will get a login failed error when trying to create the database." Sharepoint is in a seperate domain than SQL and there isn't a trust between the two.
In the config screen, I've entered the server/instance and sql ID and PW that has rights to create the database: sqlServerName\Instance; user id=someuser; password=somepassword. The database gets created with 1 table but then I get a message stating that it can't log in a different user, this user is from the domain that Sharepoint is in and I'm not sure why it is using that ID for this. We monitored SQL and can see that our 'someuser' is creating the db, starting the db, checking the db, then switches context to try and use a SharePoint domain account, I'm guessing to do the rest of the table creation, which won't work. The monitoring showed that the sql account actually tried to run an sp to create the user from the other domain. I don't understand why the context switching is taking place since we've given it the sql account and it worked to create the database. What item is sending that instruction (Sharepoint?) and is there a way around this. In order to create our Sharepoint databases we had to use the Psconfig tool to get around the issue of sql authentication and seperate domains; I'm guessing we are going to need a similiar tool to get the SLK installed correctly since we aren't going to allow a trust.
Is there any help out there for this?